Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    2

    Asus G751JT can't see my new Asus RT-AX82U network

    My Laptop --> Asus G751JT
    My Router --> Asus RT-AX82U


    It is that simple. My Laptop can see my older Asus router just fine, but it doesn't see any of the networks of the new RT-AX82U.

    Both my phones can see the new router networks as well so I'm stumped. Here is what I have done:

    I created a brand new network, ensuring that the range that is being broadcast is from 20-160Hz. SSID is viewable and there are separate networks for 2.4 and 5Ghz.

    On the laptop I have deleted the Wifi and internet drivers and reinstalled with the original. --> Couldn't see the new router
    Updated those drivers to the latest Intel driver --> Couldn't see the new router
    Plugged in the old router --> Laptop sees old router

    The WIFI card in this laptop is an Integrated 802.11a/b/g/n/ac .. so there should be no issues.

    I'm stumped anyone able to offer help?

  2. #2
    ROG Guru: Blue Belt Array
    Join Date
    Nov 2012
    Reputation
    75
    Posts
    776

    Can you list exactly, the manufacturer, model, and installation configuration of the WiFi card installed in your laptop?

    Have you installed the latest ASUS Wireless Radio Control (A driver to make you switch Airplane mode(Wireless) On/Off)?

    https://dlcdnets.asus.com/pub/ASUS/G..._64_V10012.zip

    Are you using the Intel Driver Install and Support Assistant software to install and update the Intel drivers on your laptop?

    https://downloadmirror.intel.com/284...-Installer.exe
    Last edited by jdfrench3; 02-18-2021 at 07:46 AM. Reason: Added info
    G752VSK, G75VW-3D, G51J, G1S
    Homebuilt Windows Server

  3. #3
    ROG Guru: Orange Belt Array
    Join Date
    Nov 2014
    Reputation
    8
    Posts
    262

    Maybe you have set WPA3 authentication at the new router?
    Asus G751JT is NOT compatible with WPA3. WPA3 requires new hardware. But i believe SSIDs should be detected...
    Also this is WiFi6 router - maybe you should disable WiFi 6 mode in Advanced settings - Wireless - General tab?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •