Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Feb 2021

    Sound skipping issue


    I have a newly built system based on the A520M motherboard and there seems to be issues with audio. While playing media (YouTube, certain games), there are instances where chunks of audio are skipped. I tried drivers from both Microsoft (10.0.19041.264 ) and latest Realtek drivers. The issue is especially pronounced with Realtek (6.0.8955.1). Looks more as a software/driver issue than hardware. I tried posting this in AMD forums but was suggested to post here instead.

    My specs:

    CPU: 3500X
    RAM 16 GB


  2. #2
    New ROGer Array
    Join Date
    Feb 2021

    After quiet some time hunting down the issue. I think I solved it. Looks like there are some sort of driver conflicts.

    Two driver files audioendpoint.inf and c_swdevice.inf have the same versions (10.0.19041.1) but DIFFERENT driver dates. The first one has 12/06/2019 while the second one has 06/21/2006. Is this even possible?
    Click image for larger version. 

Name:	2006Driver.JPG 
Views:	12 
Size:	41.3 KB 
ID:	87928

    After uninstalling and scanning for hardware change in Device Manager, I got a warning in Event Log:

    Device SWD\MMDEVAPI\{}.{ba8a4a41-2189-412a-81a6-d027431da88e} was not migrated due to partial or ambiguous match.

    Last Device Instance Id: SWD\MMDEVAPI\{}.{02e8c993-5c78-44f7-ae00-bf167db655a8}
    Class Guid: {c166523c-fe0c-4a94-a586-f1a80cfbbf3e}
    Location Path:
    Migration Rank: 0xF00000000000F120
    Present: false
    Status: 0xC0000719

    After which the following log:

    Device SWD\MMDEVAPI\{}.{ba8a4a41-2189-412a-81a6-d027431da88e} was configured.

    Driver Name: audioendpoint.inf
    Class Guid: {c166523c-fe0c-4a94-a586-f1a80cfbbf3e}
    Driver Date: 12/06/2019
    Driver Version: 10.0.19041.1
    Driver Provider: Microsoft
    Driver Section: NO_DRV
    Driver Rank: 0xFF0000
    Matching Device Id: MMDEVAPI\AudioEndpoints
    Outranked Drivers: c_swdevice.inf:SWD\GenericRaw:00FF3001
    Device Updated: false
    Parent Device: HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_104386C7& REV_1003\5&319e220&1&0001

    Hence as of now audioendpoint.inf is loaded and the sound issue is fixed.

    The only bummer is that the below listed items have no drivers loaded. Device Manager says "No driver files are required or have been loaded for this device". Weird!
    Click image for larger version. 

Name:	nodriver.JPG 
Views:	12 
Size:	13.9 KB 
ID:	87929

  3. #3
    ROG Guru: Green Belt Array MoKiChU PC Specs
    MoKiChU PC Specs
    MotherboardASUS ROG Strix Z370-F Gaming
    ProcessorIntel Core i7-8700K
    Memory (part number)Corsair Vengeance RGB DDR4 2666MHz CL16 - 16GB (2 x 8GB)
    Graphics Card #1ASUS ROG Strix GTX 1080 Ti OC
    MonitorASUS ROG Strix XG35VQ
    Storage #1SSD NVMe Samsung 970 EVO Plus 500GB
    Storage #2SSD NVMe Samsung 960 EVO 250GB | SSD NVMe Corsair Force MP510 240GB | SSHD AHCI Seagate FireCuda 2TB
    CPU CoolerCooler Master ML240L RGB
    CaseBitFenix Enso
    Power SupplyCorsair TX850M (850W)
    Keyboard Logitech G413
    Mouse Logitech G502
    Headset/Speakers Logitech Z333
    OS Windows 11 64 bit 21H2/CO/22000.x
    MoKiChU's Avatar
    Join Date
    Aug 2013


    All the devices listed in "Audio inputs and outputs" are system devices, using system drivers which are not meant to be updated (whose version corresponds to the version of the system, Windows 10 2004/VB/19041.x in your case).

    You have an ASUS PRIME Realtek motherboard, so :

    You need Realtek Audio Drivers (UAD - ASUS ROG/TUF/PRIME RTK MB) from the first post of this thread.

    Follow scrupulously your CLEANUP process then your INSTALL process, for the next drivers packages that I would release, you will can directly follow your UPDATE process.

    If your DPC latency issue persists, in order to try to fix it, follow this process (also visible in TIPS at the bottom of all my audio drivers threads) :

    1) Disable hibernation :

    - Right-click Windows Start button then click Search.
    - Search for cmd. In the search results list, right-click Command Prompt and then click Run as administrator.
    - If/When you are prompted by User Account Control, click Continue.
    - At the command prompt, type powercfg.exe /hibernate off and then press Enter then close the Command Prompt

    2) Enable MSI (Message Signaled-based Interrupts) mode on all your supported devices (see the column "supported modes") with MSI Mode Utility (Right click on "MSI_util_v3.exe" > Run as administrator), then Apply, then close MSI Mode Utility & restart your PC

  4. #4
    New ROGer Array
    Join Date
    Feb 2021

    Thank you.

    I did as you said. The drivers have been updated and now there is one extra entry in Device Manager, which was not there before: Microphone. I don't use a microphone so I went to Realtek Audio Control and switched off "Disable front panel jack detection" and then it was gone. The strange thing is I don't use a front jack and there is nothing plugged in.

    As said before there is no sound issue as of now. Will need further testing. However, in Device Manager Windows says drivers are not required for "Speakers (Realtek (R) Audio)". I could just ignore this.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts