Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    6

    Zephyrus GU502GV Keyboard issue with ROG Live Service installed

    I'm hoping someone can help as Asus support simply said I needed to send my laptop in for a fix at my expense due to being out of warranty by a few months.

    When I have the Armoury / ROG services installed, my keyboard randomly becomes unresponsive until I do a full power cycle.

    I previosuly narrowed this down to software as it never occurred disabling ROG LIVE SERVICE however with new armoury crate versions I continue to get the problem. I'm now trying to disable the armoury crate service as well to see if that works.

    When the keyboard is non function I have an unknown USB device appear in device manager that has a hardware ID issue. The temp solution is to do a complete power cycle by removing power cable and holding power for 20 seconds.

    I've lived with this for awhile now but it's becoming so frustrating I want to get rid of the laptop and never by Asus again after having mainly ROG hardware for multiple PC builds over the years.

  2. #2
    ROG Member Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    9

    Quote Originally Posted by reaves42 View Post
    I'm hoping someone can help as Asus support simply said I needed to send my laptop in for a fix at my expense due to being out of warranty by a few months.

    When I have the Armoury / ROG services installed, my keyboard randomly becomes unresponsive until I do a full power cycle.

    I previosuly narrowed this down to software as it never occurred disabling ROG LIVE SERVICE however with new armoury crate versions I continue to get the problem. I'm now trying to disable the armoury crate service as well to see if that works.

    When the keyboard is non function I have an unknown USB device appear in device manager that has a hardware ID issue. The temp solution is to do a complete power cycle by removing power cable and holding power for 20 seconds.

    I've lived with this for awhile now but it's becoming so frustrating I want to get rid of the laptop and never by Asus again after having mainly ROG hardware for multiple PC builds over the years.
    It seems to be a hardware problem. the keyboard becomes unresponsive. I have the exact same issue.

  3. #3
    ROG Member Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    9

    Look familar?
    Miniatura de Adjuntos Miniatura de Adjuntos KBI1.jpg  


  4. #4
    New ROGer Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    6

    Quote Originally Posted by aaassddffgg View Post
    Look familar?
    That is the exact issue. I feel it is software related as it only occurs if the Armoury Crate Service and ROG Live Service are running.

    With these disabled, the issue NEVER occurs. Then I do not get to change lighting and have my power profiles running though which is a big issue for a gaming laptop!

    Support were absolutely no help and considering this seems a common issue, is pretty poor on Asus.

  5. #5
    ROG Member Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    9

    Moreover it seems to happen the most when the laptop is running on battery only and it is completely a show stopper if you are in the middle of something.

  6. #6
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    15
    Posts
    920

    Hello reaves42,
    Please refer to below link
    https://www.asus.com/supportonly/Arm...Desk_Download/
    You may try to use the uninstall tool to uninstall all the Armoury Crate related driver,
    then use the installer to install them back in correct order.
    Let me know if you still have the issue.
    Thank you.

  7. #7
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    8

    in "My Asus" app they have a Hotfix for keyboards.... maybe it is to fix this issue?

    But I also saw in the Reddit (so far 2 users) this hotfix completely kill they keyboard... but a bunch of users saying nothing happened.
    Last edited by nllelobr; 04-12-2021 at 06:33 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •