Results 1 to 3 of 3
  1. #1
    ROG Member Array sabevissia PC Specs
    sabevissia PC Specs
    MotherboardROG Maximus XI Hero (Wi-Fi)
    Processori9-9900 3.10GHz
    Memory (part number)F4-3200C16-16GVK
    Graphics Card #1Nvidia GeForce RTX 2070
    MonitorASUS MG248 & Acer KG281K
    Storage #1Samsung 250GB M2
    Storage #2Firecuda 2TB
    CPU CoolerCorsair Liquid Cooling
    CaseNZXT H500
    Power SupplyEVGA 850W Supernova
    Keyboard Razer Blackwidow X Chroma
    Mouse Razer Deathadder Essential
    Headset Razer Nari Essential
    Mouse Pad Acer Predator
    OS Windows 10 Pro
    Network RouterNetgear R6300v2

    Join Date
    Feb 2021
    Reputation
    10
    Posts
    7

    Maximus XI Hero (Wi-Fi) Bluetooth No Longer Working

    For some reason bluetooth just took a nosedive on my PC here. The BT Support Service is running, restarts with no error. I can see the BT Network Connection listed under Network Connections in the control panel. It's status is always "Not connected" and I can't get it to connect. In the Device Manager I see a disconnected device named "IBtUsb_Filter_00" that the Device Manager thinks is disconnected from the PC. There is also a device named "SdlRouterService" when I am able to pair my phone (or any other device) with my PC. But I still can't get call or audio support via Bluetooth, just initial pairing.

    At this point I am pretty sure the BT adapter has taken its last breath and is dead in the water. So does anybody know what the recommended Wireless Cards are for this motherboard? Something I can slip into one of the PCI slots that handles both BT and Wi-Fi for me. Unless someone else has another suggestion to try to bring BT support back to the built-in motherboard support.

  2. #2
    ROG Guru: Orange Belt Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus XIII Hero
    Processori9 11900K
    Graphics Card #1EVGA RTX 3090 FTW
    Sound CardOn Board
    MonitorDell AW3420DW
    Storage #1Samsung 980 Pro 2 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard ASUS Strix Flare
    Mouse ASUS Chakram
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000/AXE11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X52

    Join Date
    Jan 2014
    Reputation
    18
    Posts
    422

    I was going to mention something else in addition to the Reinstall. I believe your board uses an Intel 9560 Wi-Fi card. If so, it relies on some chipset/processor components to make it work, so make sure and update those..

    Some of those IBtUSb type devices are for things I don't understand but if a specific device is not currently available, some such indications may show up. There is a Your Phone app in the app listing on the Start Menu..

    I use this forum also since I have a Z370 board
    Last edited by Saltgrass; 02-27-2021 at 08:32 PM.

  3. #3
    ROG Member Array sabevissia PC Specs
    sabevissia PC Specs
    MotherboardROG Maximus XI Hero (Wi-Fi)
    Processori9-9900 3.10GHz
    Memory (part number)F4-3200C16-16GVK
    Graphics Card #1Nvidia GeForce RTX 2070
    MonitorASUS MG248 & Acer KG281K
    Storage #1Samsung 250GB M2
    Storage #2Firecuda 2TB
    CPU CoolerCorsair Liquid Cooling
    CaseNZXT H500
    Power SupplyEVGA 850W Supernova
    Keyboard Razer Blackwidow X Chroma
    Mouse Razer Deathadder Essential
    Headset Razer Nari Essential
    Mouse Pad Acer Predator
    OS Windows 10 Pro
    Network RouterNetgear R6300v2

    Join Date
    Feb 2021
    Reputation
    10
    Posts
    7

    Going to give it another try.

    Ok so an update on my situation at this point.

    After working with support via email they did finally give me two USB 2.0 BT Adapter options that are supposedly compatible with my MB. They are fairly cheap so I am likely going to get one for my PC, even if I can figure out how to fix the onboard BT. They listed USB-BT400 and USB-BT500 as the options.

    So on to what originally drove me to posting asking for input on compatible cards. About mid February of this year I suddenly lost BT functionality, well at least part of it. At first just the audio stopped working for BT. So when trying to use my PC's headphones to listen/talk when on a phone call using the "Your Phone" Windows app. I could still dial from my computer and start the call, but just would not keep audio on via BT as it just kept dropping right after trying to turn it on. Later the same day BT connections dropped all together. I could no longer dial from the phone app on my computer along with not being able to hear the audio. The odd part is that as far as Windows appears to be concerned BT is supposedly working even though nothing can actually connect. The computer can Pair with a device and will even show that paired device in the Printers and Devices window. It just won't actually connect for call or audio support. You can attempt for both and they will try for about 20 to 25 seconds and then just stop and show as disconnected. The only thing update wise that was done prior to the issue starting around 2/18/2021 was an Windows update to version 20H2 about a week before and then a driver update for BT a day or two before.

    So, I have gone through a lengthy troubleshooting phase with this MB, Drivers and Windows OS itself lol. Below is a basic summary of all that has been done with some updates along the way. Also to note, prior to this issue starting on 2/18/2021 there were no "Other devices" devices showing up. Windows was able to identify all installed hardware on my PC and had working drivers.

    1. Initially when issue started I tried taking all Updates under Windows Update, even the optional ones. (Did not fix BT issue, but did cause an "Other devices" IBtUsb_Filter_00 device to show as disconnected)
    2. Updated MB BIOS & Firmware. (Did not fix the BT issue)
    3. Turned off MB BT/Wireless support, removed all drivers/devices from Windows and rebooted. Then re-enabled BT/Wireless support in MB BIOS and rebooted. Windows did install all devices/drivers except one for the "Other devices" IBtUsb_Filter_00 not being able to be identified by Windows and thus no driver installing for it.
    4. I rolled back Windows to the version prior to 20H2 and updated all Drivers for the rolled back version. (Did not fix the BT issue and the unknown IBtUsb_Filter_00 was still showing up)
    5. I completely cleaned the OS HD (which is the SSD in this PC) and reinstalled the latest edition of Windows 10 Pro, version 20H2. I updated all drivers again and downloaded WiseRegistryCleaner, Restoro & PC HelpSoft Driver Updater and ran them. Applied fixes, missing drivers and allowed other system fixes for issues to be applied. (Did not fix the issue)
    6. During this time I discovered a difference in the BT Driver and how the IBtUsb_Filter_00 would show as disconnected with version "22.30.0.4" while with version "21.110.0.3" it would show as connected. This was an improvement over previous standing as the device was at least connected to the system now even though Windows still couldn't identify it. (Did not fix BT issue though this did allow the system to start being able to at least pair with various devices though calls or audio could not connect)
    7. I had updated/installed Pandora on my android phone yesterday and my PC actually detected this via the BT pairing my PC has with this phone when I got home and turned the PC on. I know this because under "Other devices" in Device Manager another device named PandoraLink now shows up as connected when my phone is there even though Windows can't identify the appropriate hardware/software so it can't find a Driver.

    So at this point I would love any helpful input you guys/gals could give me that may help resolve my issue. Specifically I need to find the appropriate Bluetooth Filter Driver for this Motherboard (ROG Maximus XI Hero Wi-Fi) to install. I am pretty sure if I get that installed my PC should then be able to connect for calls/audio with my other BT devices (such as my phone, tablet and TV's). Please let me know what other information you need from my end. I have already updated my profile with my system specs and they are still accurate for what I currently have in this PC. Thanks again for your effort and assistance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •