Results 1 to 10 of 19

Threaded View

  1. #1
    ROG Member Array
    Join Date
    Nov 2020
    Reputation
    10
    Posts
    8

    Asus Maximus Extreme XII Z490 - Intel Core i7 11900k - Bios 2004 MB cant power on !

    As iam always an early adopter, i had a rare chance to get my hands on an 11700k early and first i tried with already installed 2002 on my MB. It was very bugged, booting took 30 seconds till i saw a picture, IF i got a picture at all, trying to OC fails immediatly, couldnt alter few settings in the bios like Sync all cores to 53, as soon ive set it to 53 it revereted back to 50 automatically. My 3090rtx was powered with X16 1.1... so i decided to flash the newest firmware 2004 with bios flashback but after i saw the Updating Intel ME and the screen turned black and the mainboard switched off, its impossible to power it on again... its not starting anymore. I did flashback several times now ith 2004, always the same result. No starting of the Mainboard.

    Asus, PLEASE !!! if you put something into public, test it yourself before doing so ! you make ENOUGH money on a Mainboard which was 990€. I expect quality not only in Hardware but also in the Software you put on your boards.

    update: i fixed it by updating BOTH bios on the board.
    Last edited by mmolletit; 03-01-2021 at 03:53 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •