Results 1 to 9 of 9
  1. #1
    ROG Member Array
    Join Date
    Aug 2011
    Reputation
    10
    Posts
    13

    Here comes a very usefuel tip for armoury crate reinstallation

    The Problem:
    After uninstall (complete with deleting folders, services etc..) and reinstall of Armoury Crate, the hardware devices will no longer discovered by the Armoury Crate software.

    The solution:
    1.) Please open the attached screenshot.
    2.) Got to the registry keys in the big red racetangle.
    3.) Copy the "uninstall string" from every line in the big racetangle to clipboard and paste into windows cmd (started as admin) and run.
    4.) Boot the pc.

    Now you can reinstall the Armoury Crate and all hardware will discoverd.

    PS:
    It could be, you have more or less keys with uninstall string. It depends on how much ASUS devices you are using :-)
    Miniatura de Adjuntos Miniatura de Adjuntos rogarmoury-uninstall.jpeg  

    Last edited by whiggy; 03-13-2021 at 06:49 AM.

  2. #2
    ROG Enthusiast Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    25

    tnx for this.my issue is i cant even install armory crates,as it get stock at end of installation.

  3. #3
    ROG Member Array
    Join Date
    Aug 2011
    Reputation
    10
    Posts
    13

    Asus should overhaul the uninstall routine. But my tipp is working. I tested this for many times.

  4. #4
    ROG Junior Member Array
    Join Date
    Jun 2013
    Reputation
    10
    Posts
    4

    I cant even fin the reg keys, and still having issues " No devices available " in armoury crate

  5. #5
    ROG Enthusiast Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    25

    i also cant find the reg keys nothing work ,im tired and no update from asus

  6. #6
    New ROGer Array Jimbo93 PC Specs
    Jimbo93 PC Specs
    Laptop (Model)ABS Master Gaming PC
    MotherboardASUS Prime B560M-A AC
    ProcessorINTEL i5 10400F
    Memory (part number)G.SKILL F4-3200C16D-16GVKB x 2
    Graphics Card #1ASUS DUAL RTX 3060 Ti
    Sound CardRealTek HD
    MonitorSAMSUNG 40" LCD
    Storage #1INTEL SSD PEKNW512GB NVMe
    CPU CoolerThermaltake
    CaseASUS
    Keyboard ASUS K1
    Mouse ASUS M1
    Headset/Speakers Cambridge Works PC
    OS Win 10 Home

    Join Date
    Oct 2021
    Reputation
    50
    Posts
    83

    Looks very helpful, thank you

    Quote Originally Posted by whiggy View Post
    The Problem:
    After uninstall (complete with deleting folders, services etc..) and reinstall of Armoury Crate, the hardware devices will no longer discovered by the Armoury Crate software.

    The solution:
    1.) Please open the attached screenshot.
    2.) Got to the registry keys in the big red racetangle.
    3.) Copy the "uninstall string" from every line in the big racetangle to clipboard and paste into windows cmd (started as admin) and run.
    4.) Boot the pc.

    Now you can reinstall the Armoury Crate and all hardware will discoverd.

    PS:
    It could be, you have more or less keys with uninstall string. It depends on how much ASUS devices you are using :-)

  7. #7
    New ROGer Array Jimbo93 PC Specs
    Jimbo93 PC Specs
    Laptop (Model)ABS Master Gaming PC
    MotherboardASUS Prime B560M-A AC
    ProcessorINTEL i5 10400F
    Memory (part number)G.SKILL F4-3200C16D-16GVKB x 2
    Graphics Card #1ASUS DUAL RTX 3060 Ti
    Sound CardRealTek HD
    MonitorSAMSUNG 40" LCD
    Storage #1INTEL SSD PEKNW512GB NVMe
    CPU CoolerThermaltake
    CaseASUS
    Keyboard ASUS K1
    Mouse ASUS M1
    Headset/Speakers Cambridge Works PC
    OS Win 10 Home

    Join Date
    Oct 2021
    Reputation
    50
    Posts
    83

    So After uninstalling AC and AI Suite 3, I searched the whole registry for the Value 'UninstallString' without the quotes. It found pretty much all my other installed software, but there were no ASUS entries found with that Value. And the Uninstaller did work after 1 fail and reboot.

  8. #8
    ROG Enthusiast Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    25

    i have managed to do this.unistall .remove those registries but still ac cant detect my mb.
    it can see m tuf 3080 but not my mb.
    armoury crate work properly but my motherboard missing .
    very enjoying.

  9. #9
    New ROGer Array Jimbo93 PC Specs
    Jimbo93 PC Specs
    Laptop (Model)ABS Master Gaming PC
    MotherboardASUS Prime B560M-A AC
    ProcessorINTEL i5 10400F
    Memory (part number)G.SKILL F4-3200C16D-16GVKB x 2
    Graphics Card #1ASUS DUAL RTX 3060 Ti
    Sound CardRealTek HD
    MonitorSAMSUNG 40" LCD
    Storage #1INTEL SSD PEKNW512GB NVMe
    CPU CoolerThermaltake
    CaseASUS
    Keyboard ASUS K1
    Mouse ASUS M1
    Headset/Speakers Cambridge Works PC
    OS Win 10 Home

    Join Date
    Oct 2021
    Reputation
    50
    Posts
    83

    Quote Originally Posted by Peyman1354 View Post
    i have managed to do this.unistall .remove those registries but still ac cant detect my mb.
    it can see m tuf 3080 but not my mb.
    armoury crate work properly but my motherboard missing .
    very enjoying.
    One thing I have figured out, is that the software that gets left behind after an uninstall, lets call it the "ATK software" is required in order for the motherboard to be identified. When I received my new system and booted it the first time, Armoury Crate was installed and it worked, but I was unhappy with the crashing services. So I uninstalled it from control panel. This was before I had even seen the uninstaller tool. I had trouble reinstalling it and somehow the "ATK software" got messed up. It took me better part of a weekend to get it working again. And the only was was to manually remove the ATK stuff. If it is removed it will automatically be reinstalled when you try to install AC. I am still working on those additional instructions on how to remove the "ATK software". One of the symptoms of broken ATK software is that the atkexcomsvc.exe fails to start, but keeps trying for maybe 2 minutes after a reboot. I also experienced that it interfered with my network adapter while it was trying to start. In windows services it is named asComSvc, but if you look at what file is pointed to it is atkexcomsvc.exe. Another symptom is that Armoury Crate fails to initialize, or takes a really long time to initialize. Initializing happens the first time it is run.
    Another piece of the atk software is the asusCertService. But this ATK software needs to be removed (manually) from your system. Then you will be good to reinstall.
    Last edited by Jimbo93; 10-14-2021 at 11:59 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •