Results 1 to 4 of 4
  1. #1
    New ROGer Array BiggShooter's Avatar
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    32

    Multiple RMA's - Same Issue | Asus ROG Rapture GT-AX11000

    I purchased the Asus ROG Rapture GT-AX11000 back in January 2020. *In January 2021, I determined that LAN4 would not establish an internet connection to a wired device utilizing that port. *On 02/19, I contacted ASUS Tech Support, and a RMA was issued (RMA #USBVM20863 / Case #2102060355)

    On 02/28, I received a brand new / factory sealed ASUS ROG Rapture GT-AX11000. *I set up / configured the router and utilized all the LAN ports on the router, including the 2.5G Gaming Port (connected to Xbox Series X using CAT7 ethernet cable). *In less than a week, the 2.5G Gaming Port failed, as my Xbox Series X was unable to connect to Xbox Live. *It was determined that the 2.5G Gaming Port failed (Status showed 'Unplugged' in GT-AX11000 GUI). *On 03/07, I contacted Asus Tech Support, and a SECOND RMA was issued (RMA #*USBVM30387)

    On 03/17, I received a brand new / factory sealed ASUS ROG Rapture GT-AX11000. *I set up / configured the router and utilized all the LAN ports on the router, including the 2.5G Gaming Port (connected to Xbox Series X using CAT7 ethernet cable). *Later that evening, the 2.5G Gaming Port failed [AGAIN], as my Xbox Sereis X was unable to connect to Xbox Live. *Instead of requesting a RMA, I contacted Asus Tech Support (evening of 03/24) and requested the next level tier of Tech Support. My case (Case #N2103073395) was escalated the next level tier of Tech Support. *Between 03/24 and 03/31, I was contacted (either by phone or email) by four different people from Asus Tech Support. *None of the four individuals were from the next level tier Tech Support. *In one instance, the Asus Tech Support Representative requested the make / model of the 2.5G Ethernet Adapter I was using. *This was NEVER about an ethernet adapter. *It was about my Xbox Series X being connected to the 2.5G Gaming Port and failing to connect to Xbox Live after some time. *Due to my frustrations with Asus Tech Support, I contacted Asus Tech Support, and a THIRD RMA was issues (RMA #USBVM31554).

    Rather than continuing to send me brand new / factory sealed routers, how about someone from Asus Tech Support (top tier Tech Support / Engineer) contact me to figure out why the 2.5G Gaming Port continues to fail! *Ridiculous I have to keep sending in routers! *This has to be a hardware issue. *I requested Asus to send me the ASUS ROG RAPTURE GT-AXE11000 to test in my home network enviromnent, *however I was informed they are all out of stock.

    I'm hoping to get somewhere in regards to this frustrating and unessecary game of sending routers back to Asus.*

  2. #2
    Moderator Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    86

    My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. If you would allow, I would be more than glad to help provide a resolution to this case. Please email me with the below details so I can work with related personnel to get this straightened out.

    Product S/N:
    RMAs #:
    Full name:
    Email:
    Router's Firmware version:
    Ports status from GUI:
    (Example: https://postlmg.cc/QVYb3Gx9)

    My email is cl-adrian@asus.com.:
    You can also provide feedback using the router's built-in feedback option (GUI > Administration > Feedback) to send additional information.

    In the meantime, try initializing your router via firmware.
    How to initialize:
    https://www.asus.com/us/support/FAQ/1035717/

  3. #3
    New ROGer Array BiggShooter's Avatar
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    32

    Quote Originally Posted by cl-Adrian@ROG View Post
    My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. If you would allow, I would be more than glad to help provide a resolution to this case. Please email me with the below details so I can work with related personnel to get this straightened out.

    Product S/N:
    RMAs #:
    Full name:
    Email:
    Router's Firmware version:
    Ports status from GUI:
    (Example: https://postlmg.cc/QVYb3Gx9)

    My email is cl-adrian@asus.com.:
    You can also provide feedback using the router's built-in feedback option (GUI > Administration > Feedback) to send additional information.

    In the meantime, try initializing your router via firmware.
    How to initialize:
    https://www.asus.com/us/support/FAQ/1035717/
    Thanks for the reply. I've sent an email with the requested information.

  4. #4
    New ROGer Array BiggShooter's Avatar
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    32

    Asus Support is HORRIBLE BAD! Since sending an email on 04/05 to Adrian from Asus Customer Loyalty Team, I've received no response! *NOTHING! I guess I wasted my time providing the information requested.

    On Friday, I had to call Asus Support regarding my RMA, since it was showing "Thanks for your inquiry! Service center has arranged to exchange your device" for three days. After contacting ASUS, I was informed they needed my authorization to ship out a replacement! WTH! The last two replacements shipped out without my authorization. The Customer Support representative created a "escalation ticket" for the Service Center. Today, I got a call from Asus Customer Support, just to tell me the Service Center currently does not have any replacements in stock to send me. I questioned why I could buy one on the Asus Store. Asus Customer Support indicated the Asus Store is separate from the Service Center. WTF!

    This is, by far, the WORST support I've ever experienced! With no resolution from anyone, including Adrian, I will never buy another ASUS product again! HORRIBLE! HORRIBLE! HORRIBLE!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •