Results 1 to 5 of 5

Threaded View

  1. #1
    ROG Enthusiast Array BiggShooter's Avatar
    Join Date
    Jan 2020
    Reputation
    10
    Posts
    32

    Multiple RMA's - Same Issue | Asus ROG Rapture GT-AX11000

    I purchased the Asus ROG Rapture GT-AX11000 back in January 2020. *In January 2021, I determined that LAN4 would not establish an internet connection to a wired device utilizing that port. *On 02/19, I contacted ASUS Tech Support, and a RMA was issued (RMA #USBVM20863 / Case #2102060355)

    On 02/28, I received a brand new / factory sealed ASUS ROG Rapture GT-AX11000. *I set up / configured the router and utilized all the LAN ports on the router, including the 2.5G Gaming Port (connected to Xbox Series X using CAT7 ethernet cable). *In less than a week, the 2.5G Gaming Port failed, as my Xbox Series X was unable to connect to Xbox Live. *It was determined that the 2.5G Gaming Port failed (Status showed 'Unplugged' in GT-AX11000 GUI). *On 03/07, I contacted Asus Tech Support, and a SECOND RMA was issued (RMA #*USBVM30387)

    On 03/17, I received a brand new / factory sealed ASUS ROG Rapture GT-AX11000. *I set up / configured the router and utilized all the LAN ports on the router, including the 2.5G Gaming Port (connected to Xbox Series X using CAT7 ethernet cable). *Later that evening, the 2.5G Gaming Port failed [AGAIN], as my Xbox Sereis X was unable to connect to Xbox Live. *Instead of requesting a RMA, I contacted Asus Tech Support (evening of 03/24) and requested the next level tier of Tech Support. My case (Case #N2103073395) was escalated the next level tier of Tech Support. *Between 03/24 and 03/31, I was contacted (either by phone or email) by four different people from Asus Tech Support. *None of the four individuals were from the next level tier Tech Support. *In one instance, the Asus Tech Support Representative requested the make / model of the 2.5G Ethernet Adapter I was using. *This was NEVER about an ethernet adapter. *It was about my Xbox Series X being connected to the 2.5G Gaming Port and failing to connect to Xbox Live after some time. *Due to my frustrations with Asus Tech Support, I contacted Asus Tech Support, and a THIRD RMA was issues (RMA #USBVM31554).

    Rather than continuing to send me brand new / factory sealed routers, how about someone from Asus Tech Support (top tier Tech Support / Engineer) contact me to figure out why the 2.5G Gaming Port continues to fail! *Ridiculous I have to keep sending in routers! *This has to be a hardware issue. *I requested Asus to send me the ASUS ROG RAPTURE GT-AXE11000 to test in my home network enviromnent, *however I was informed they are all out of stock.

    I'm hoping to get somewhere in regards to this frustrating and unessecary game of sending routers back to Asus.*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •