Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Apr 2021

    Question TUF Z590 Plus Gaming WiFi Bios 405 not upgradeable

    Dear ASUS community,

    I'm having an issue with my new TUF Z590 Plus Gaming WiFi motherboards bios.

    The system is running very well, but I wanted to update to the latest bios.
    When looking at the support page of the motherboard, I can see the following bios versions:

    My current bios version is 405. When I try to update to 811 or 820, the system goes into a restart loop, powering on an off two times every second. I let it run for a couple of minutes one time, but figuring it would not be beneficial to the hardware, eventually turned it off.
    I tried that two times each, always with the same result. The processor and dram Q-leds blink when the update is started and the board is going into the power on/off loop.
    The system recovery with flashback works, reverting to 405 each time.

    Is anybody else experiencing similar issues?

    Any feedback is much appreciated, thank you!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts