Results 1 to 3 of 3
  1. #1
    ROG Member Array rudeboi PC Specs
    rudeboi PC Specs
    Motherboardrog maximus xii formula
    Processor10900k
    Memory (part number)32gb corsair vengence 3200mhz 4x8
    Graphics Card #1980ti
    Monitorbenq xl2720t
    Storage #1512 m.2
    Storage #21tb hdd
    CPU Coolercustom water cooling
    Caselian li 011d xl
    Power SupplyZalman ZM1000-HP
    Keyboard roccat ryos
    Mouse roccat tyon
    Headset astro a50 gen 4
    OS win 10

    Join Date
    Mar 2013
    Reputation
    10
    Posts
    10

    rog maximus vii formula bios help

    i have just updated the bios to latest version 0901 as i have had a issue with lan everytime i turn my pc on it allways state's i dont have a internet connection but if i do a restart it works but if i shut down then turn back on does the same so thought i would just do a fresh install of the o/s but upon booting from usb it will not show up my m.2 in the select drive to install on so ive tried various bios setting but cannot seem to fix it im not A WIZ KID WHEN IT COMES TO BIOS I i only know basics from trying to read the manual or if i even have set the bios up right at all

    anyone able to help/ educate me on what im doin wrong

    many thanks

  2. #2
    ROG Member Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    5

    what LAN device ?
    Intel® I225-V 2.5Gb Ethernet or Marvell® AQtion AQC107 10Gb Ethernet


    try install latest drivers....

  3. #3
    ROG Guru: Orange Belt Array Mike Kelly's Avatar
    Join Date
    Nov 2013
    Reputation
    14
    Posts
    443

    [QUOTE=rudeboi;820364]i have just updated the bios to latest version 0901

    Hello Rudeboi, When I look at the VII Formula bios downloads,

    3503 4-26-2018
    3003 10-28-2015 are the 2 newest Bios that are available.
    0901 is something I am not familiar with, so could You please explain where You DL'ed 0901 ?
    I do believe the LAN update is much newer then 2018. I have my own card and do not use ROG Lan drivers.

    Thanks for the info as I am having a lot of problems with both of the above Bios and could never understand
    why Asus would stop supporting such an expensive MB that is still very good in 2021.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •