Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    5

    PLEASE HELP! Performance Issues

    Hello and Good day!

    I have i7-10700K
    Strix B460 F
    32GB Ram
    NVM.e SSD
    Strix 3070 OC
    Windows 10 Pro
    and running 1440p on monitor

    softwares installed:
    nvidia experience
    game first VI
    armoury create

    When playing Warzone, I get massive FPS drops after playing some time, like 40-80fps from 100-140fps. Also when playing Genshin Impact I got also massive FPS drops.

    while playing on my brothers pc which have lower specs didn't have fps drop issues

  2. #2
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    170
    Posts
    2,193

    Hello, Update to the latest Nvidia Game Ready drivers. You might want to try downloading and running latencymon to see if this flags any services running high DPC latency.

  3. #3
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Silent Scone@ROG View Post
    Hello, Update to the latest Nvidia Game Ready drivers. You might want to try downloading and running latencymon to see if this flags any services running high DPC latency.
    Hi, thank you for your quick response. Unfortunately all drivers are already up to date using nvidia experience and armoury crate. That's why I can't seem to find out why I am still having FPS drop issues.

  4. #4
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    170
    Posts
    2,193

    Quote Originally Posted by j0hnp4ul View Post
    Hi, thank you for your quick response. Unfortunately all drivers are already up to date using nvidia experience and armoury crate. That's why I can't seem to find out why I am still having FPS drop issues.


    Check out latencymon as suggested. It may point you in the right direction. https://www.techspot.com/downloads/6944-latencymon.html

  5. #5
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Silent Scone@ROG View Post
    Check out latencymon as suggested. It may point you in the right direction. https://www.techspot.com/downloads/6944-latencymon.html
    Click image for larger version. 

Name:	latencymon1.jpg 
Views:	20 
Size:	173.9 KB 
ID:	88436

    This is the conclusion so far. Should I follow the suggestion? Would this help?

  6. #6
    Administrator Array Silent Scone@ROG's Avatar
    Join Date
    Mar 2016
    Reputation
    170
    Posts
    2,193

    Quote Originally Posted by j0hnp4ul View Post
    Click image for larger version. 

Name:	latencymon1.jpg 
Views:	20 
Size:	173.9 KB 
ID:	88436

    This is the conclusion so far. Should I follow the suggestion? Would this help?
    This process is part of Microsoft's Drive Framework and might not be the route course of the issue. Visit the Intel Download Center and download the latest chipset drivers for your board https://downloadcenter.intel.com/pro...sktop-Chipsets

    You may wish to update drivers for any or all audio devices.

    Lastly, run DDU and remove the NVIDIA GPU driver completely before reinstalling.

    If all else fails, sometimes it's quicker to install a dummy operating system on a separate drive to see if the issue persists on a clean OS.

  7. #7
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Silent Scone@ROG View Post
    This process is part of Microsoft's Drive Framework and might not be the route course of the issue. Visit the Intel Download Center and download the latest chipset drivers for your board https://downloadcenter.intel.com/pro...sktop-Chipsets

    You may wish to update drivers for any or all audio devices.

    Lastly, run DDU and remove the NVIDIA GPU driver completely before reinstalling.

    If all else fails, sometimes it's quicker to install a dummy operating system on a separate drive to see if the issue persists on a clean OS.
    Ok, I was wrong about all drivers are up to date. Seems like I missed the BIOS update. Updating now and also the chipset of Strix B460 F. Will update you, thank you!

  8. #8
    New ROGer Array
    Join Date
    Jul 2019
    Reputation
    10
    Posts
    4

    Not sure if you managed to fix your problem, however, I wanted to share a potential option to look into. According to Nvidia and Microsoft, a couple of recent updates KB5001330 and KB5001337 caused a lot of problems (FPS drops etc) for many users. Microsoft even admitted to it and promised to deploy a hotfix. You can read about it here, for example: https://www.pcgamer.com/the-windows-...as-been-fixed/.

  9. #9
    New ROGer Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    2

    Im having performance issues as well, i7 10700, ROG strix motherboard,

    Armoury crate keeps saying "This app can't run on your PC to find a version for your PC , check with the software publisher"....But i downloaded the right one for this motherboard ROG Strix z490-E gaming , Gtx 980 HOF,

    I really dont know why it wont let me run this.. and also my pc freezes on screen (no blue screen) it just freezes up randomly...

    I cant make my own post because this forum wont let me for no evident reason as a new comer but i really need help with this

    My CPU constantly Reads 50 Celcius, if that has any relation to it..?
    Last edited by chakan117; 04-25-2021 at 07:34 PM.

  10. #10
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    5

    Hello! Sorry for the late reponse! I was having issues coming back, when I tried, asus won't let me. I don't know why. I always get this message(attached image).

    I tried running DDU and completely re-installed my GPU Driver, after that my FPS drops from Genshin Impact got fix and I also got FPS improvement from Warzone. But still after a few games, the FPS still drops down to 70+ from 140+.

    Should I provide dxdiag and msinfo files?Click image for larger version. 

Name:	asus issue (2).jpg 
Views:	0 
Size:	342.3 KB 
ID:	88609

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •