Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array Calligo PC Specs
    Calligo PC Specs
    MotherboardAsus Maximus Ranger VII
    ProcessorIntel Core i7 4790k
    Graphics Card #1Asus Radeon R9 270x
    MonitorLG W2261
    Storage #1Western Digital Green 3TB
    Storage #2Samsung 840 Evo
    CPU CoolerNoctua NH-D14
    CaseFractal Design Define R5
    Power Supplybe quiet! L8 CM 530W
    Keyboard Sharkoon Skiller Pro
    Mouse Sharkoon Drakonia
    Headset Turtle Beach Tango
    OS Windows 10 Pro
    Network RouterThompson

    Join Date
    Sep 2015
    Reputation
    10
    Posts
    1

    Asus FX516PR 11th Gen Intel Has No Backlight after installing new NVME

    Hey! :-)
    I have got some issues with my new gaming notebook. First I installed a new NVME drive and wiped all the bloatware etc from the existing 1TB NVME. After a few hours of research I found out on Tiger Lake I first need an IRST driver to get windows to show any nvme ssd. Long story short I fixed the problem and was happy with my shiny new machine , but now I found out that I should have a green-blueish backlight, that I am not able to turn on. To be exact I have had no backlight at all since I got the laptop.

    I did some research and found information on how the solution could be to toggle some switches in Asus Armoury Crate app cause asus has driver issues- I installed "TUF Aura Core" and of course I got all the latest drivers from the asus website too. No success so far. And to get this out of the way too, no I dont have the backlight turned off with FN+F2, I read that this human error is very common , so I ruled that out first.

    Does anyone have an idea how to get this worked out? I`m playing around with this issue since a few days now and its getting more and more frustrating. I installed. reinstalled and deinstalled various asus apps and drivers, but no success.

    Im thankful for every help I can get and hope I`m somehow able to fix this.

    Greetings from austria!

  2. #2
    ROG Enthusiast Array rcarlos243 PC Specs
    rcarlos243 PC Specs
    Laptop (Model)Asus G751JT
    MotherboardGigabyte X99 SOC-FORCE
    ProcessorIntel Core i7 5820k @4.5Ghz 1.28vcore
    Memory (part number)16GB DDR4 2666 CL13 Quad Channel
    Graphics Card #1R9 290 4GB @1150 core w/ Corsair H105 + 2x Gentle Typhoon AP15
    Sound CardFiiO E17 USB AMP/DAC
    MonitorBenQ XL2420z 1080p 144Hz
    Storage #1256GB Samsung SM951 NVMe M.2
    Storage #2960GB Crucial M500
    CPU CoolerEK Supremacy Evo, 360mm HWLabs Black Ice GTX, 360mm Swiftech MCRX20-QP, Swiftech MCP655, 6x AP15's
    CasePhanteks Enthoo Pro
    Power SupplySeasonic SS-600XP2 80 Plus Platinum
    Keyboard Logitech G710+ Cherry MX Brown
    Mouse Logitech G502
    Headset Philips Fidelio X2
    Mouse Pad Razr HardMatt
    OS Windows 10
    Network RouterNetgear Nighthawk X6 R8000

    Join Date
    May 2014
    Reputation
    8
    Posts
    43

    If you still have the old NVMe and you have a desktop computer that has multiple NVMe slot I suggest you clone the old NVMe into your new one.


    Also it is not a good idea to remove the stock ASUS apps as it controls many things (screen and KB back light, FAN, turbo, Power Limit, etc...)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •