Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Jan 2021
    Reputation
    10
    Posts
    3

    Question G512LW-ES76 • Weird Display Issue

    I purchased this ROG Strix laptop (G512LW-ES76) about four months ago last year in December 2020 & it has been an enjoyable experience up until some time in the month of April. Where I started experiencing this weird display issue that is becoming more and more frustrating. Its difficult for me to explain the problem so I've attached some photos that demonstrates the issue.

    This happens every time I power on the laptop and also whenever the display is woken up from sleep mode, in other words anytime the display has to turned on. The only way I've found so far that can get the display to show normally is by cycling the power button on and off until the display starts to show a proper image. I'm unable to determine whether this is a hardware (as in, the display is going bad) or a software issue.

    I tried following some troubleshooting tips from here, but to no avail. Has anyone experienced anything like this and know of a way to fix this issue?
    Miniatura de Adjuntos Miniatura de Adjuntos 20210508_063155.jpg  

    20210508_063158.jpg  

    20210508_063203.jpg  

    20210508_063207.jpg  

    20210508_063216.jpg  


  2. #2
    New ROGer Array
    Join Date
    Jan 2021
    Reputation
    10
    Posts
    3

    Post Update

    Upon further testing I've determined that it's most likely a hardware issue, as the problem doesn't exist while using an external display. Tough I'm still unsure whether its the display panel itself, the ribbon cable that connects the panel to the main-board or the GPU.

  3. #3
    New ROGer Array
    Join Date
    Jan 2021
    Reputation
    10
    Posts
    3

    Post Update 2

    All the info I've looked at online suggests that somehow the ribbon cable is no longer connected properly and that it is not necessarily that the cable has gone bad. I don't quite understand how this happened as I've never moved the laptop from the spot I placed it since I got it months ago, but whatever I guess.

    The problem now is that I can't find any guides on how to connect the cable properly for my specific model G512LW-ES76. I don't want to open the thing up with no idea or reference as to what I'm doing.

  4. #4
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    344
    Posts
    8,034

    If you are still within the warranty period (and it sounds like you are) I would send it in for RMA. There's no way to tell from the outside if it's a poorly seated cable, damaged cable, or something else.

    If you do decide to open it you don't need your exact hardware configuration, just a teardown of something in that line of machines.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •