Results 1 to 1 of 1

Threaded View

  1. #1
    New ROGer Array
    Join Date
    May 2021

    LED on motherboard Stopped working on Strix Z370 E

    Hi guys, this is my first post here!
    So, a few months ago, my rgb led located on the upper left corner of my Z370-E, stopped working after i turned on my pc the same way I'm used to.
    So I tried removing Aura and reinstalling first newer versions, then some old versions. I gave up pretty quickly and I assumed that it was just broken.
    But Today I read that some people were having the same issues (Turn on>Led flashes>Other leds light up>Mobo led still off), and so I decided to give it an other go.
    I tried with Armoury software but still nothing, I turned on and off the led in The BIOS... still nothing. I even tried resetting the mobo by removing the battery! Now I almost lost hopes, so I'm asking for your help, because the MOBO itself is the best I've ever tried and thats the only issue that I encountered. :(

    Anyways, thanks for your time.

    -Sorry for my bad english

    Windows 10 pro x64
    I5 8600k 5ghz
    16gb 3200Mhz
    Windows installed on ssd nvme (samsung 960 evo)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts