Results 1 to 4 of 4
  1. #1
    ROG Guru: Yellow Belt Array
    Join Date
    Dec 2013

    z490/z590 bios will not flash, possible solution

    Since Rocket Lake release I have seen quite a few people post about the board acting like it is dead or one of the bios will not flash on a dual bios MB like Apex.
    I ran into the same issue with z490 Unify and 11900k where the MB would not do anything.

    Someone on a German site just posted about this with z590 Hero and 11900k and they could not get the MB to post or flash the bios via flashback. I suggest removing everything(so just MB and PSU) and then try flashback and it worked for him so posting it here. Try it as a last chance if nothing else works.

    Disconnect everything, Sata, NVME, RAM, CPU etc. and then try flashback

  2. #2
    ROG Guru: Green Belt Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus XIII Hero
    Processori9 11900K
    Graphics Card #1EVGA RTX 3090 FTW
    Sound CardOn Board
    MonitorDell AW3420DW
    Storage #1Samsung 980 Pro 2 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard ASUS Strix Flare
    Mouse ASUS Chakram
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000/AXE11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X52

    Join Date
    Jan 2014

    I suppose a question I might ask is why go through all that trouble when you can just do it from the Bios using EZ Flash. I can see the attraction if the Bios Flashback worked but unplugging everything is a little more than should be required.

    I will try it the next time I do a Bios update..

  3. #3
    ROG Guru: Yellow Belt Array
    Join Date
    Dec 2013

    The reason to do this is you cannot even boot the MB so how could you do EZ flash?

    It is a last resort and no reason to do unless nothing else works. I said in the first post the board acts like it is dead or the board does nothing.

    Also it may not work and the bios is still bricked.
    Last edited by bscool; 05-14-2021 at 06:47 AM.

  4. #4
    ROG Guru: Brown Belt Array MrAgapiGC PC Specs
    MrAgapiGC PC Specs
    MotherboardAsus Maximus XI Code
    Memory (part number)CMK32GX4M4B3600C18
    Graphics Card #1STRIX-GTX1080ti-O8G-GAMING
    MonitorAOC AGON AG2701QX (2)
    Storage #1Samsung 960 EVO 256GB
    Storage #2Kingston Savage 500GB
    CPU CoolerNzxt X74 360mm AIO
    CaseNzxt H700
    Power SupplyEVGA 850 G2
    Keyboard Logitech G810
    Mouse Asus Spartha
    Headset Hyper X Cloud Revolver S
    Mouse Pad Hyper X Fury S 900mx420mm
    Headset/Speakers Logitech Z337
    OS Windows 10 64btis
    Network RouterTpLink Archer C9
    Accessory #1 EKWB FANs all of them
    MrAgapiGC's Avatar
    Join Date
    Nov 2011

    i check a guy locally with the same issue. using a z590-e with a 10700k once he update the bios, did the flashback, turn on the pc, load the lights update and then ... that is it. I will meet the guy today to check that out
    Learn, Play Enjoy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts