Results 1 to 3 of 3
  1. #1
    ROG Member Array bhutchins1a PC Specs
    bhutchins1a PC Specs
    MotherboardMaximus XII Extreme
    ProcessorIntel Core i9 10900K
    Graphics Card #1Nvidia GEForce 980TI
    Keyboard Razer Battlefield 3
    Mouse Logitech G501
    Headset Astro A4
    OS Windows 10 64 bit

    Join Date
    Aug 2012
    Reputation
    10
    Posts
    5

    Maximus XII Extreme ethernet adapters download limited to 95 Mbps

    Hello,

    Sorry if this is a repeat question but I can't figure out how to search the forum.

    I have a ROG Maximus XII Extreme motherboard with 64GB memory and a lot of bells and whistles. It comes with an Intel I225v 2.5Gbps NIC and a Marvel 10Gbps NIC. I have an Intel Core i9 10900K that's not overclocked.

    I can't get over 95 Mbps (WAN and LAN) out of either adapter.

    I have tried my 6-year old ROG G751 gaming laptop on it and the download speeds are consistently in the 170Mbps range (about what I'd expect for that laptop).

    I have tried my relatively new Dell XPS-7390 with a USB-C to Ethernet adapter (and use the same CAT 5e cable as on my Maximus XII Extreme) and achieved 470Mbps download speed.

    My WiFi 6 card on my Maximus XII Extreme gets 470Mbps download speed, too (on WiFi).

    Here's what I've done:
    1) Unplugged and replugged cable from switch to the wall outlet,
    2) Punched down the cables on the wall outlet connector,
    3) Tested continuity on all 4 pairs (all good - good enough to get 470Mbps on the Dell),
    4) Updated the controllers for both NICs,
    5) Updated the drivers for both NICs,
    6) Disabled and re-enabled the drivers for both NICs,
    7) Uninstalled the drivers for both NICs,
    8) Reinstalled the drivers for both NICs,
    9) Restarted the computer with each change

    FWIW - I have two M.2 cards in play and that takes out one of the PCI lanes (I think but not 100% certain)

    The NICs act like they're throttled because the speed test (speedtest.net) is consistent every test - 95Mbps down/ 12Mbps up.

    I couldn't find anything in the manual or in the BIOS settings (it'd have to be real obvious in the BIOS settings because I'm not a BIOS guy - so I might have missed something).

    It's probably something obvious and simple that I'm missing, but I'd greatly appreciate any help! (It just doesn't seem right that a 6-year old laptop would have a higher download speed than this fancy motherboard. And it's really sad to have a little bitty Dell laptop that's a year older than my motherboard gets 5 times the download speed from the same cables.)

    Thanks!
    ROG Maximus XII Extreme
    Intel Core i9 10900K 3.7 GHz (Turbo to 5.2 GHz)
    64 GB G.Skill
    EVGA GeForce GTX 980Ti
    Kracken X73 Closed Loop Cooling System
    Samsung 980 PRO 2 TB NVME M.2 SSD

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    329
    Posts
    7,932

    I'd also check to see if you have the newest chipset driver. Beyond that I'm not sure if there are any related BIOS settings. I doubt there would be anything that would force it to operate at such a slow speed so it sounds like a bug or hardware issue more than a setting.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    I just boght recently an Asus ROG Strix Z590 and I just noticed that it drops ethernet while my sons are playing Minecraft.

    Every time they are playing Minecraft, the network conection just drop.

    And another interesting thing, is that when it happens, the computer don't finish the Windows 10 turn off proceadure, or even restart proceadure. It initiate the process, but when the screens go black, it just freeze. Power button don't work, reset button don't work also. Just hard reset.

    Researching my problem, find out lot's of people with bouth problem... with other MB brands, or MB Asus models! For me, it's an Intel I225V problem.

    Try here...

    https://www.intel.com/content/www/us...to-2-5gbe.html

    https://community.intel.com/t5/Ether...s/td-p/1188301

    https://www.reddit.com/r/intel/comme...h_intel_i225v/

    Already try everything, no success yet. About to return my board and trying another brand that uses another ethernet controller, cause all the best Asus MB are using Intel I225V controller.

    Best of luck,

    André

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •