Results 1 to 3 of 3
  1. #1
    ROG Member Array Haggisdog PC Specs
    Haggisdog PC Specs
    MotherboardMaximus IV Extreme
    Graphics Card #1XFX Radeon 6870
    Graphics Card #2XFX Radeon 6870
    Graphics Card #3XFX Radeon 6870
    CPU CoolerAntec Kuler Pro 640
    CaseCoolerMaster 690 II Advanced
    Power SupplyTargan 900W
    Keyboard Steelseries Merc
    OS Windows 10
    Haggisdog's Avatar
    Join Date
    Jul 2017
    Reputation
    31
    Posts
    13

    Exclamation ROG Strix GL504GS USB HUB keeps disconnecting keyboard/mouse

    I have a ROG Strix GL504GS that I have connected to a Samsung 4k 32" monitor and supported by a cooling platform. The laptop is plugged in and temps are all normal. For some of my peripherals like my Razor Chroma Mouse and Keyboard I am using a powered 10port Anker USB hub. It also supports my Logitech USB camera and headset.

    Long story short, the keyboard and mouse constantly disconnect although the timing on this can vary widely. I can go several hours without an issue to having them disconnect every few minutes. When I plug the keyboard and mouse directly to the USB connections on the laptop they are stable.

    This is the second USB powered HUB I have tried (I originally thought that the issue was related to the manufacturer) however I am experiencing the same issue.

    I have updated every driver, disabled power management on all the HUB devices and ensured Windows is up to date.

    I recently replaced the GPU fans as one of the ball bearings was noisy but other than that the machine is performing extremely well.

    When the external keyboard and mouse disconnect the onboard keyboard and mouse continue to work.

    I can live with connecting the keyboard and mouse directly to the laptop but I don't have enough USB connections for my other peripherals so I need some kind of HUB.

    Has anyone else experienced this or have any ideas on how to resolve this issue?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    329
    Posts
    7,928

    I'm guessing you've tried connecting the hub to the other ports on the laptop? If you haven't I would definitely try that.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Member Array Haggisdog PC Specs
    Haggisdog PC Specs
    MotherboardMaximus IV Extreme
    Graphics Card #1XFX Radeon 6870
    Graphics Card #2XFX Radeon 6870
    Graphics Card #3XFX Radeon 6870
    CPU CoolerAntec Kuler Pro 640
    CaseCoolerMaster 690 II Advanced
    Power SupplyTargan 900W
    Keyboard Steelseries Merc
    OS Windows 10
    Haggisdog's Avatar
    Join Date
    Jul 2017
    Reputation
    31
    Posts
    13

    Using other ports

    Quote Originally Posted by xeromist View Post
    I'm guessing you've tried connecting the hub to the other ports on the laptop? If you haven't I would definitely try that.
    Thanks for the suggestion and I did indeed try that but it was the same behavior on each port. I'm under the impression that devices with alot of traffic like a keyboard or mouse might have some lag that exceed some buffer and leads to a disconnect. There are three USB ports on this laptop so I have my mouse and keyboard attached directly and a Hub that supports my Webcam, Headphones and a WiFi range extender. So far everything has been stable and there have been no disconnects so I guess I can mark this issue as resolved.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •