Results 1 to 4 of 4
  1. #1
    ROG Junior Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    Armoury Crate only working with administrator accounts

    Why does Armoury Crate require admin user to be logged in?

    For security purposes I always use a regular Windows user account as my daily driver. When I try to use Armoury Crate with that user and access my ROG Falchion keyboard's settings, it doesn't open. If I login with my admin account and open Armoury Crate everything works fine.

    ASUS needs to correct this security flaw that you are only able to use Armoury Crate if you have admin account logged in.

  2. #2
    ROG Junior Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    Do ASUS employees even read this forum? I still have a couple of days left to return my keyboard and I think I will since there is zero support from ASUS.

  3. #3
    New ROGer Array
    Join Date
    May 2021
    Reputation
    10
    Posts
    2

    I have same issue, and seem reading this forum is way too much to request as their help desk is not too helpful with this. They stop answering to support ticket after this helpful comment. And yes, I still don't have a nice day with my Armoury Crate.

    ________________________________________
    Hi,

    If it doesn't open with standard, then it sounds like some permission issue or another program is blocking it. Try to use clean boot to see if some software is blocking the settings.

    Have a nice day!

  4. #4
    ROG Junior Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Harry Salenius View Post
    I have same issue, and seem reading this forum is way too much to request as their help desk is not too helpful with this. They stop answering to support ticket after this helpful comment. And yes, I still don't have a nice day with my Armoury Crate.

    ________________________________________
    Hi,

    If it doesn't open with standard, then it sounds like some permission issue or another program is blocking it. Try to use clean boot to see if some software is blocking the settings.

    Have a nice day!
    I have a test laptop and I installed a fresh Windows 10 Home x64 with latest H121 update included. I created 2 users, Admin user and a Regular user. Armoury Crate was the ONLY app that I installed and it had the same problem. Admin user works and Regular user does not work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •