Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array
    Join Date
    Apr 2019
    Reputation
    10
    Posts
    26

    i have a question about asus website

    Hello,

    when on the rog website i clicked on the above right asus logo and it leads me to https://www.asus.com//be-nl/
    I mean is it a bad joke or is it really two slashes for the asus local website?

    In any cases i can't access it. There is a big Oops

    Help needed please,

    Arn

  2. #2
    ROG Enthusiast Array Banditt1976 PC Specs
    Banditt1976 PC Specs
    MotherboardASUS ROG STRIX X570-E Gaming
    ProcessorAMD Ryzen 9 5900X @ 4700 MHz
    Memory (part number)G.SKILL TridentZ RGB F4-4000C17-8GTZR 32 GB @ 4000 MT/s CL16
    Graphics Card #1ASUS ROG STRIX RTX 3070 Gaming OC @ 2070 MHz Boost Clock
    MonitorLG UltraGear 27GL850-B 27" QHD 144 Hz
    Storage #1Samsung 980 Pro 1 TB PCIe 4.0
    Storage #2Samsung 970 EVO 500 GB PCIe 3.0
    CPU CoolerThermalTake Floe DX RGB 360 mm AIO Liquid Cooling
    CaseCorsair 5000X RGB ATX Mid-tower
    Power SupplyASUS ROG STRIX 850W Fully Modular
    Keyboard SteelSeries APEX 5 RGB
    Mouse Logitech M500 Laser Mouse
    Mouse Pad SteelSeries QCK PRISM RGB Gaming
    Headset/Speakers Bose Companion 5
    OS Windows 10 Pro
    Network RouterNetgear Nighthawk X4S R7800
    Banditt1976's Avatar
    Join Date
    Mar 2021
    Reputation
    10
    Posts
    34

    Just remove the extra "/" and the website will load. I did that and it loaded correctly for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •