Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    New ROGer Array ipalchuk PC Specs
    ipalchuk PC Specs
    MotherboardAsus Rog Crosshair VIII Dark Hero
    Memory (part number)HyperX DDR4 16GB (2x8GB) 4600Mhz
    Graphics Card #1MSI GeForce RTX 3090 SUPRIM X 24
    Storage #1Samsung 980 PRO V-NAND MLC 1TB M.2
    CPU CoolerBQ Pure Loop 360
    Power SupplyBQ Dark Power Pro 1200W
    OS Windows 10 HE x64

    Join Date
    May 2021
    Reputation
    10
    Posts
    4

    AI Suite 3 (3.00.79) - ERROR "The server threw an exception"

    All latest and updated.
    After some time of work (2-3 hours) - this error appears.
    No programs were launched or closed.
    Remove from tasks and start again - does not help. Only reboot helps.
    All this on the new system. I was worn out for 2 days with the program "Armoury Crate".
    (wrote about my suffering in the appropriate forum: Armoury Crate 4.0.8.0 BUG Tracer)
    This program works, but occasionally crashes.
    I don't understand THIS company has its own QA department or ordinary users have to do this work for free and suffer from bugs ???
    Does anyone (from the tech department of this company) read these forums ? if reads - does something ?
    Click image for larger version. 

Name:	AISuiteServerError.jpg 
Views:	0 
Size:	162.0 KB 
ID:	88854

    An interesting situation comes out, people buy your product very expensively, but from the technical point of view, they only have problems. It's a shame. You are repeating "Sony" story. The days of "Trinitron" are over. Now the important thing is adequate software.
    Last edited by ipalchuk; 05-28-2021 at 09:34 PM.

  2. #2
    ROG Junior Member Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    4

    I have the same problem on my newly-built machine with ROG STRIX Z579-A Gaming Wi-Fi motherboard. The problem occurred both with AiSuite 3 that followed on the supplied DVD, and with the updates to v.3.00.76 and v.3.00.79. I used AI3Cleaner and rebooted between the installs.
    Click image for larger version. 

Name:	AISuite 3 Exception.jpg 
Views:	0 
Size:	203.1 KB 
ID:	89005

    The bug manifests itself a few hours after a reboot. From my observations it seems that system load and how often the system needs to change the speed of the fans plays a role in how soon the problem occurs.
    Once the exception windows start rolling, the only way to stop them is to kill AiSuite3 from the Details view in Windows Task Manger.
    An attempt to start AiSuite3 after kill will result in 2 Exception windows popping up and the program terminating.

    A some occasions I got a different exception, saying that FanExpert4 module cannot start more threads.

    This, combined with a delayed nature of the failure leads me to believe that there is a resource leak in the FanExpert4 module, whereupon new threads are started during fan speed changes, but are never properly disposed.

    In the end I was forced to completely uninstall AiSuite3. Before doing that, I noted the fan speeds that worked the best with my system and plotted them in the QFan modile in system BIOS.

  3. #3
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    9

    ME too in B460 F and error disappear, when kill 'ASUS Motherboard Fan Control Service (32 bit)' process in Task Manager

  4. #4
    ROG Junior Member Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    4

    An interesting observation regarding Services. As I wrote above, I uninstalled AiSuite and ran AiCleaner with a subsequent reboot, yet when took a look at the list of the services tab in the Task Manager, I see 4 Asus services, some of them still running:
    Click image for larger version. 

Name:	Asus services.jpg 
Views:	0 
Size:	23.2 KB 
ID:	89008
    AsusFanControlService is among them.
    An idea: when you next get that cascade of exceptions, maybe it would suffice to right-click on that service and Restart it, instead of killing it outright?

  5. #5
    New ROGer Array scostigan PC Specs
    scostigan PC Specs
    MotherboardROG Maximus Extreme XIII
    Processori9-10900K
    Memory (part number)G.Skill F4-4000C18D-128GTZR
    Graphics Card #1Nvidia 3090 FE
    MonitorLG CX 48"
    CPU CoolerCustom WC.
    CaseMeshify 2 XL
    Power SupplySeasonic 1000w Platinum
    OS Windows/Linux/Vmware

    Join Date
    Jun 2021
    Reputation
    10
    Posts
    2

    I have been having the same error with my new builds

    I have been having the same error with my new builds, Z590(10900K) maximus extreme xiii and a X570(5950x) Dark Hero viii.

    I have downloaded the new updates and still crashes randomly.

    It seems like this is standard fare for this software for over 4 years.

    Is there a viable replacement for this????

  6. #6
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    9

    Quote Originally Posted by Nemo1024 View Post
    An interesting observation regarding Services. As I wrote above, I uninstalled AiSuite and ran AiCleaner with a subsequent reboot, yet when took a look at the list of the services tab in the Task Manager, I see 4 Asus services, some of them still running:
    Click image for larger version. 

Name:	Asus services.jpg 
Views:	0 
Size:	23.2 KB 
ID:	89008
    AsusFanControlService is among them.
    An idea: when you next get that cascade of exceptions, maybe it would suffice to right-click on that service and Restart it, instead of killing it outright?
    Service also restarts, after the killing.

  7. #7
    New ROGer Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    1

    The same for me.

    i thought it was because I changed my CPU but I did a clean install and it still happens.

  8. #8
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    9

    Quote Originally Posted by joethedemon View Post
    The same for me.

    i thought it was because I changed my CPU but I did a clean install and it still happens.
    "AsusFanControlService" version?

  9. #9
    ROG Junior Member Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    4

    I have two versions under C:\Program Files (x86)\ASUS\AsusFanControlService
    2.00.97 and 2.01.05
    The latter one is being launched at start-up despite complete uninstall of AiSuite3

  10. #10
    ROG Member Array
    Join Date
    Apr 2021
    Reputation
    10
    Posts
    9

    Quote Originally Posted by Nemo1024 View Post
    I have two versions under C:\Program Files (x86)\ASUS\AsusFanControlService
    2.00.97 and 2.01.05
    The latter one is being launched at start-up despite complete uninstall of AiSuite3
    Update to a new version 2.01.07. It maybe solves the server threw an exception" error.

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •