Results 1 to 2 of 2
  1. #1
    ROG Junior Member Array
    Join Date
    Jul 2017

    Exclamation GX551QS Power Connector Not Plugged In Properly Warning using USB-C PD

    I have a problem where when I charge my laptop (GX551QS-XS99) while playing a game, I get a popup every 30 seconds that tanks my performance - going from hundreds of FPS to sub 30 + visual and audio stutter. The warning is "The power connector is not plugged in properly. Please disconnect and reconnect the power adapter." It only happens when I am:

    Charging using USB-C PD

    Playing a game

    If I close the popup the performance gets better again, but it will reappear soon. It appears to be from the MyAsus app. Is there something that can fix this? I've tried the following power sources:

    1. Apple 87W USB-C charger
    2. Anker PowerCore III Elite 87W power bank
    3. Apple USB-C 100W PD cable and Anker PowerLine III 100W PD cable

    I suspect it might have something to do with it being 87W instead but I can't verify that since I don't have a 100W charger on hand.

    Also, I've been experiencing stutters that last a few seconds every minute or so when I have the option "Balanced Mode" selected in the MyAsus battery health charging setting. It happens when I'm doing anything, even programming, which is frustrating.

    I've tried:

    1. Disabling battery health charging setting - Did not fix warning popup, did fix other stutter issue.
    2. Different power sources and cables as said before - Didn't work.
    3. Using regular 280W brick - Works as intended.
    4. Disabling Nvidia battery boost via Geforce Experience - Did nothing, it wasn't even turned on when using USB-C PD as expected.
    5. Forcing Nvidia GPU for game - It didn't do anything, popup does not appear to be switching GPUs to integrated anyway.

    All tested using Performance mode in Armoury Crate.

    Games run at near full FPS on battery only and when plugged into PD (before the popup appears) so it seems like it's not like the system is running out of power. Even if it's discharging faster than it can charge with PD plugged in, it should have enough power from the battery anyway.

    Is there a solution? Do I just need to get a 100W charger? I'd like to keep MyAsus to have the battery optimizer on. And that's causing issues with my regular programming use as well. I'd prefer to not just uninstall it altogether to keep the battery healthy. Or am I just SOL?

    Click image for larger version. 

Name:	Annotation 2021-05-30 034452.png 
Views:	2 
Size:	53.2 KB 
ID:	88860

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010

    USB doesn't deliver enough power to charge and power components while doing anything intensive. And using an undersized charger is going to fool the machine into thinking it's charging but it won't get enough power. The regular power brick really should be used when gaming but if you want to use it in this manner you might have to remove the software.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts