Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    May 2021
    Reputation
    10
    Posts
    2

    STRIX H370-I board doesn't boot, possibly an incompatible CPU?

    Building out a PC for my brother who doesn't have a lot of money, so we decided to save and get him a board from ebay. I managed to find this board decently cheap and I had an i5-9600k and 2x 8GB corsair RAM sticks I had upgraded from so I figured it would be perfect. I have built many many computers, so this isn't some brain dead easy problem (at least I hope not...)

    Symptoms: Lights come on, fan spins, my USB test light turns on, QLED lights go CPU on then off, then RAM goes on then off, and that's it, VGA and boot LED never comes on and computer never posts, I also don't get any beeps. There is an orange LED on the opposite side of the board that I can't seem to get any information on. It turns on as soon as I power the board and stays on until I turn it off at the PSU.

    I have tried pulling the board and booting with everything removed except CPU and RAM, tried a different known good PSU (first is a corsair 650w, second is a corsair 430w), tried with onboard graphics as well as the RX480 card I'm putting in there for him (I know it sucks, but it's the best I had), made sure a good fan was plugged into the CPU fan header, checked voltages with the system running.

    The CPU and RAM were moved directly from my old computer to this one.

    After extensive troubleshooting I decided to check the compatibility list on the ASUS website and I discovered that support for the i5-9600k was added with an early BIOS update. I messaged the seller on ebay and he said the board had never had any issues but he was using an i7-8700k and he had never updated the BIOS, so it's possible that this was an early board that didn't get the first BIOS update, but before I put the effort into figuring out a way to update the BIOS (such as a loaner CPU or FlashCAT USB SPI programmer) I figured I would see what others thought.


    PS. the board doesn't support Asus flashback and my attempts at using CrashFree BIOS 3 to restore the BIOS have failed, the LED on my trusty USB "flash" drive never comes on no matter what port I try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •