Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    4

    ASUS ROG Claymore II number pad issue

    Hi,

    I've had a Claymore II keyboard for a few days now and it worked absolutely fine to start with. Now though, there's a problem with the number pad.

    It has started randomly spamming numbers (2, 5 or 8) and occasionally the decimal point or +. Also using the volume scroller inputs a 5. Disconnecting the number pad stops the problem.

    This happens both in wired and wireless mode, and on both sides of the keyboard. I've checked that the connectors are clean, and there's no sign of damage or jammed keys. I've got the latest updates installed via Armoury crate.

    I've also plugged the keyboard into other devices (an older Asus laptop, a Surface Pro 7 and an Xbox Series X), and the problem persists on all of them when the number pad is attached.

    Has anybody else experienced this, and is there a fix? Or will I have to send the keyboard back?

    Thanks in advance for any help

  2. #2
    New ROGer Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    4

    Latest update. I've installed the 10th June 2021 firmware update and things have improved slightly, however the middle set of numbers and decimal point still won't work, and will occasionally spam 2 or 5, although this now stops by pressing any of the other number keys on the pad.

    It's looking like a firmware issue, I've seen another post where the volume control on the numpad didn't work after a firmware update...

    Is there any way to do a factory reset on this keyboard?

  3. #3
    New ROGer Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    4

    I received my replacement today, works fine, just not going to update the firmware this time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •