Results 1 to 1 of 1
  1. #1
    ROG Member Array
    Join Date
    May 2018
    Reputation
    21
    Posts
    10

    Tuf Z390m-Pro Gaming issues with MS outlook

    I have a very weird issue, I have two identical computers in my office, both using Tuf Z390m-Pro Gaming motherboard, i5 CPU, 16gb ram. Both have pretty much identical software configuration Windows 10 and Office 2019. Both computers are used purely for office tasks, word and excel documents and Outlook for email. Everything seems to work fine, except Outlook - it sometimes freezes up where it takes several minutes to connect to server and disconnect from server. The only thing that helps is to uninstall and reinstall office, or reinstall windows, or delete and create a new user.

    In the same office I have two more systems with identical purpose and identical software configuration, but they are running ROG STRIX Z370-G GAMING motherboards, also with i5 CPUs and 16gb ram. These two system work just fine, never any issues with outlook.

    I am thinking there might be something wrong with network adapters on the Tuf Z390m-Pro motherboards, whether its hardware of the drivers. Running latest drivers and BIOS, but this problem has been ongoing since 2018 or 2019 when I set the systems up, and never resolved with any of the driver updates. I had a number of Asus motherboards in the past with NIC issues, I'm thinking this is one more.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •