Results 1 to 2 of 2
  1. #1
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    657

    On laptop lid close/reopen drivers loose color settings and extra EDID custom screens

    I have a laptop ASUS ROG Scar GL703GS (details in signature) and I've found that closing/reopening the lid (= Sleep and resume) causes the NVidia driver to loose all custom color settings and extra EDID custom screens I created with CRU (Custom Resolution Utility).
    To restore colors and EDID customized settings I can run CRU's 'restart64.exe' and everything goes back to normal.

    I already tried with DDU to clean up and reinstall drivers from safe mode but didn't solve the issue, which seems to me a Windows 10 or NVidia driver issue, or maybe a BIOS/ASUS issue.
    If I manually enter Sleep mode (no lid closing or I close the lid after) and resume there is no issue.
    I also tried to assign Hibernation to lid closing action instead of Sleep, but there was the same issue.

    Win 10 21H1 (19043.1055)
    NVidia driver 466.77
    Gaming Laptop ASUS GL703GS (BIOS 310)32GB (dual channel) DDR4 2666MHz
    CPU i7-8750H (iGPU unavailable)
    GTX 1070 8GB (Max-P, 10DE 1BE1 - 1043 1011, GP104 A1, vbios 86.04.7c.00.24, Samsung VRAM)
    Screen: 144Hz g-sync AUO B173HAN03.2 [AUO329D] 1080p (1920x1080)
    2nd Screen through DisplayPort: 144Hz adaptive-sync Mi UWQHD [XMI3444] 3440x1440
    Audio: Realtek HD Audio (ALC295 chipset)
    Hard disks: NVMe Samsung, SSD Crucial
    USB Blu-Ray 4K drive: Archgon Star MD-8102P-U3YC-UHDB (Pioneer BDR-UD04)

  2. #2
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H
    Processori7-8750H
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 10 PRO x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015
    Reputation
    27
    Posts
    657

    It seems after closing/reopening the lid, internal laptop monitor changes to a different HW ID. The clue is in some ghost and inactive devices that pops-up from nowhere!!!



    DISPLAY\AUO329D\5&1217B8D&4&UID0 not present after EDID reset, before I close/reopen the lid
    DISPLAY\AUO329D\5&1217B8D&4&UID4352 this is how is always displayed once fully resumed

    WORKAROUND
    My current workaround has been to re-create NVidia custom monitor resolutions + color settings for BOTH screens* (!?), this grants not to loose my customizations when closing the lid to put laptop in Sleep/Hibernation.

    *i.e. make my customizations, close and reopen the lid and re-create the same settings also on this "new" screen
    Last edited by hexaae; 06-16-2021 at 12:18 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •