Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    ROG Member Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    9

    Question M2 drive not seen by Z590-E in the PCIe 4.0 slots

    Hi,

    I recently purchased the Z590-E motherboard. Overall I'm very happy with it, but there's issue I can't figure out.

    I have a Samsung 980 Pro M2 drive, but for some reason the motherboard won't recognize the drive when put in the upper slot that support PCIe 4.0, ie. the M2_2 slot (or M2_1 for that matter).

    However, the M2 drive is detected, when inserted into the M2_4 slot. However, this one does not support PCIe 4.0. I use a 10600K CPU as a placeholder, until I can purchase the 11900K. But as long as the PCIe 4.0 slots don't work, I can't get any benefits from my PCIe 4.0 M2 drive.

    Is there a setting in the bios I've overlooked, or is this a bug in the bios?

    Thanks! *

  2. #2
    ROG Guru: Yellow Belt Array Zardoc PC Specs
    Zardoc PC Specs
    MotherboardASUS ROG Strix Z590-A Gaming WiFi 6 Intel® Z590 LGA 1200 PCIe 4.0
    ProcessorIntel® Core™ i7-11700 Processor 16M Cache, up to 4.90 GHz
    Memory (part number)Corsair Vengeance LPX 32GB (2x8GB) DDR4 3200MHz CL16 Memory Kit - Black (CMK16GX4M2B3200C16)
    Graphics Card #1ASUS Dual GeForce RTX™ 2070 OC edition 8GB GDDR6 Clock 1410 MHz Memory Clock 1750 MHz
    Sound CardOnbard Realtek 4080
    MonitorLG 27UK850-W 27'' 4K UHD IPS
    Storage #1Samsung 980 pro M.2 256 GB Pcie Gen 4.0
    Storage #2Samsung 970 Evo M.2 2280 2tb Pcie Gen3. X4
    CPU CoolerCryorig H7 Tower Cooler For AMD/Intel CPU
    CaseFractal Design Define R5 ATX Mid Tower Window Case Titanium 2X5.25 1X3.5 8X3.5IN
    Power SupplyCorsair AXi Series AX860i Digital 860W 80 PLUS
    Keyboard Logitech K800
    Mouse Logitech 705
    Headset/Speakers Klipsch THX
    OS Win 10 Ent 19043
    Network RouterAsus RT-AC86U

    Join Date
    Apr 2013
    Reputation
    47
    Posts
    137

    Hi Mike,

    M.2_1 cannot be used. Saved for CPU Tiger Lake.

    PCIe 4.0 will be activated with 11th gen processor.

    Use either M.2_2 or M.2_3

  3. #3
    ROG Guru: Orange Belt Array Jesseinsf PC Specs
    Jesseinsf PC Specs
    Laptop (Model)N/A
    MotherboardASUS ROG Maximus XI Extreme (Z390)
    ProcessorIntel Core i9 9900K
    Memory (part number)Corsair CMW128GX4M4E3200C16 - 128GB (4x32)
    Graphics Card #1NVIDIA - GeForce RTX 2080 Ti FE
    Sound CardOnboard TOSLINK to powered speakers
    MonitorMSI Creator PS321URV (32 in 4k HDR600)
    Storage #1Samsung 980 Pro M.2 PCIe SSD 1TB
    Storage #2Samsung 970 Pro M.2 PCIe SSD 1TB
    CPU CoolerLian Li Galahad 360 (3x Uni fan SL120)
    CaseLian Li PC-011 Dynamic XL Black (ROG Certified)
    Power SupplyCooler Master V1200 Platinum
    Keyboard RAZER HUNTSMAN ELITE - LINEAR OPTICAL SWITCH (Red) w/ PBT Keycaps
    Mouse Razer Basilisk Ultimate with Charging Dock
    Headset Bowers and Wilkins P9 Signature
    Mouse Pad LOFTMAT (16x13 inch) Cushioned Gaming Mat - "The Gaming Slim"
    Headset/Speakers Vanatoo Transparent One Encore with Rel HT/1003 Subwoofer
    OS Windows 11 Pro for Workstations 64-bit
    Network RouterROG Rapture GT-AC5300 (Using Spectrum 400MB service)
    Accessory #1 Microsoft Xbox Elite Wireless Controller Series 2
    Accessory #2 2x Logitech BRIO ULTRA HD PRO WEBCAM
    Accessory #3 7 Uni Fan SL120 fans for PC case
    Jesseinsf's Avatar
    Join Date
    Mar 2019
    Reputation
    45
    Posts
    389

    Quote Originally Posted by Mike43 View Post
    Hi,

    I recently purchased the Z590-E motherboard. Overall I'm very happy with it, but there's issue I can't figure out.

    I have a Samsung 980 Pro M2 drive, but for some reason the motherboard won't recognize the drive when put in the upper slot that support PCIe 4.0, ie. the M2_2 slot (or M2_1 for that matter).

    However, the M2 drive is detected, when inserted into the M2_4 slot. However, this one does not support PCIe 4.0. I use a 10600K CPU as a placeholder, until I can purchase the 11900K. But as long as the PCIe 4.0 slots don't work, I can't get any benefits from my PCIe 4.0 M2 drive.

    Is there a setting in the bios I've overlooked, or is this a bug in the bios?

    Thanks! *
    You need 11th Gen processors for it to work.

  4. #4
    ROG Member Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    9

    Thanks for the replies.

    The manual for Z590-E states that the M2_1 is for 11. gen CPUs only, however slot M2_2 supports both 10th and 11th gen CPUs, yet the motherboard doesn't detect my 10600K CPU in the M2_2 slot. Am I missing something here?

    Thanks again for the help.

  5. #5
    ROG Guru: Yellow Belt Array Zardoc PC Specs
    Zardoc PC Specs
    MotherboardASUS ROG Strix Z590-A Gaming WiFi 6 Intel® Z590 LGA 1200 PCIe 4.0
    ProcessorIntel® Core™ i7-11700 Processor 16M Cache, up to 4.90 GHz
    Memory (part number)Corsair Vengeance LPX 32GB (2x8GB) DDR4 3200MHz CL16 Memory Kit - Black (CMK16GX4M2B3200C16)
    Graphics Card #1ASUS Dual GeForce RTX™ 2070 OC edition 8GB GDDR6 Clock 1410 MHz Memory Clock 1750 MHz
    Sound CardOnbard Realtek 4080
    MonitorLG 27UK850-W 27'' 4K UHD IPS
    Storage #1Samsung 980 pro M.2 256 GB Pcie Gen 4.0
    Storage #2Samsung 970 Evo M.2 2280 2tb Pcie Gen3. X4
    CPU CoolerCryorig H7 Tower Cooler For AMD/Intel CPU
    CaseFractal Design Define R5 ATX Mid Tower Window Case Titanium 2X5.25 1X3.5 8X3.5IN
    Power SupplyCorsair AXi Series AX860i Digital 860W 80 PLUS
    Keyboard Logitech K800
    Mouse Logitech 705
    Headset/Speakers Klipsch THX
    OS Win 10 Ent 19043
    Network RouterAsus RT-AC86U

    Join Date
    Apr 2013
    Reputation
    47
    Posts
    137

    Quote Originally Posted by Mike43 View Post
    Thanks for the replies.

    The manual for Z590-E states that the M2_1 is for 11. gen CPUs only, however slot M2_2 supports both 10th and 11th gen CPUs, yet the motherboard doesn't detect my 10600K CPU in the M2_2 slot. Am I missing something here?

    Thanks again for the help.

    Well Mike I'm at a loss. I have the same CPU as you and my Samsung m.2 was detected immediately.

    Here is a link for 490s that might help out.
    https://www.asus.com/support/FAQ/1044083/

  6. #6
    ROG Member Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    6

    I have a Z590-f and a WD SN750 drive and 10700k. So the WD SN750 is PCIE 3.0. It wasn't recognised in M2_2 either no matter what I did and had to move the drive to the M2_3 slot for it to work...Seems like an issue with the M2_2 slot on these boards, could also be an issue with the M2_1 slot also but have no way of testing it at present...

  7. #7
    ROG Guru: Orange Belt Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus XIII Hero
    Processori9 11900K
    Graphics Card #1EVGA RTX 3090 FTW
    Sound CardOn Board
    MonitorDell AW3420DW
    Storage #1Samsung 980 Pro 2 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard ASUS Strix Flare
    Mouse ASUS Chakram
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000/AXE11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X52

    Join Date
    Jan 2014
    Reputation
    18
    Posts
    424

    I was just wondering if you are using Optane memory?

    Maybe it has to do with where those M.2 slots are connected to the system. There are some on the chipset and some on the processor..

    M.2_4 does appear to be the only one that supports SATA mode..

    @Zardoc, if you have a 980, your system spec listing needs to be updated..
    Last edited by Saltgrass; 02-18-2021 at 01:59 PM.

  8. #8
    ROG Member Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    9

    Thanks for the replies.

    Saltgrass, I use regular high speed RAM - 3400mhz cl14. I've entered all my system specs into my profile, for some reason they disappeared.


    It seems like there is an issue with the motherboard, and something Asus should look into (bug, or lack of bios compability with certain M2 drives?).

    Hopefully Asus is aware of this issue, and can fix this before the 11th gen CPUs from Intel are made available.
    Last edited by Mike43; 02-23-2021 at 02:11 PM.

  9. #9
    ROG Guru: Orange Belt Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus XIII Hero
    Processori9 11900K
    Graphics Card #1EVGA RTX 3090 FTW
    Sound CardOn Board
    MonitorDell AW3420DW
    Storage #1Samsung 980 Pro 2 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard ASUS Strix Flare
    Mouse ASUS Chakram
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000/AXE11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X52

    Join Date
    Jan 2014
    Reputation
    18
    Posts
    424

    I added something to my post and the comments about your specs were not meant for you.

    Maybe the fact that last M.2 slot supports SATA means it has connections for a PCIe 4 drive.

  10. #10
    ROG Guru: Yellow Belt Array Zardoc PC Specs
    Zardoc PC Specs
    MotherboardASUS ROG Strix Z590-A Gaming WiFi 6 Intel® Z590 LGA 1200 PCIe 4.0
    ProcessorIntel® Core™ i7-11700 Processor 16M Cache, up to 4.90 GHz
    Memory (part number)Corsair Vengeance LPX 32GB (2x8GB) DDR4 3200MHz CL16 Memory Kit - Black (CMK16GX4M2B3200C16)
    Graphics Card #1ASUS Dual GeForce RTX™ 2070 OC edition 8GB GDDR6 Clock 1410 MHz Memory Clock 1750 MHz
    Sound CardOnbard Realtek 4080
    MonitorLG 27UK850-W 27'' 4K UHD IPS
    Storage #1Samsung 980 pro M.2 256 GB Pcie Gen 4.0
    Storage #2Samsung 970 Evo M.2 2280 2tb Pcie Gen3. X4
    CPU CoolerCryorig H7 Tower Cooler For AMD/Intel CPU
    CaseFractal Design Define R5 ATX Mid Tower Window Case Titanium 2X5.25 1X3.5 8X3.5IN
    Power SupplyCorsair AXi Series AX860i Digital 860W 80 PLUS
    Keyboard Logitech K800
    Mouse Logitech 705
    Headset/Speakers Klipsch THX
    OS Win 10 Ent 19043
    Network RouterAsus RT-AC86U

    Join Date
    Apr 2013
    Reputation
    47
    Posts
    137

    Quote Originally Posted by Saltgrass View Post
    @Zardoc, if you have a 980, your system spec listing needs to be updated..
    No 970 but we are talking about board seeing the drive rather than not detecting pcie 4.0 because there is no pcie 4.0 with 10th gen cpu.

    The difference is that my drive was already activated from another board. I usually activate them with a USB connection. This way, I never end up with a drive not being identified.

    Problem is that you can't activate if that's the only board you have

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •