Results 1 to 10 of 10
  1. #1
    ROG Enthusiast Array sl910 PC Specs
    sl910 PC Specs
    MotherboardMaximus 13 Hero PCB 1.02
    ProcessorIntel i9 11900K
    Memory (part number)Crucial 64 GB 3200MHz (4x16GB, CL22)
    Graphics Card #1Nvidia RTX 3090 Founders Edition
    Storage #1Samsung NVMe 980 Pro 1TB
    Storage #2Samsung NVMe 970 EVO Plus 2TB
    CPU CoolerNoctua NH-D15S chromax.black
    CaseLian-Li PC-A61WX
    Power SupplySeasonic PRIME TX-1000
    Keyboard Microsoft Wired Keyboard 600
    Mouse Microsoft Clasic Intellimouse
    OS Windows 10 Pro FR 21H1

    Join Date
    Jan 2020
    Reputation
    10
    Posts
    34

    Maximus 13 Hero new BIOS released (0902)

    Asus has officially released a new BIOS for the Maximus 13 Hero. The release notes are very very short:

    ROG MAXIMUS XIII HERO BIOS 0902
    "Improve system stability and performance.

    One can observe that the i9-11900K microcode has been updated (from 3c to 40)

    Regards

    sl91
    Last edited by sl910; 06-26-2021 at 07:31 AM.

  2. #2
    New ROGer Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    4

    BIOS 0902 bricked my motherboard.
    Nothing happens when i press power.

    Good job Asus.

  3. #3
    ROG Guru: Orange Belt Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus XIII Hero
    Processori9 11900K
    Graphics Card #1EVGA RTX 3090 FTW
    Sound CardOn Board
    MonitorDell AW3420DW
    Storage #1Samsung 980 Pro 2 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard ASUS Strix Flare
    Mouse ASUS Chakram
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000/AXE11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X52

    Join Date
    Jan 2014
    Reputation
    18
    Posts
    408

    @sl910, can we assume you actually updated your system?

    @berglake, how did you do the Bios update?

  4. #4
    ROG Enthusiast Array sl910 PC Specs
    sl910 PC Specs
    MotherboardMaximus 13 Hero PCB 1.02
    ProcessorIntel i9 11900K
    Memory (part number)Crucial 64 GB 3200MHz (4x16GB, CL22)
    Graphics Card #1Nvidia RTX 3090 Founders Edition
    Storage #1Samsung NVMe 980 Pro 1TB
    Storage #2Samsung NVMe 970 EVO Plus 2TB
    CPU CoolerNoctua NH-D15S chromax.black
    CaseLian-Li PC-A61WX
    Power SupplySeasonic PRIME TX-1000
    Keyboard Microsoft Wired Keyboard 600
    Mouse Microsoft Clasic Intellimouse
    OS Windows 10 Pro FR 21H1

    Join Date
    Jan 2020
    Reputation
    10
    Posts
    34

    Quote Originally Posted by Saltgrass View Post
    @sl910, can we assume you actually updated your system?

    @berglake, how did you do the Bios update?
    @sl910, can we assume you actually updated your system? Yes of course ! No troubles. So far so good for me

  5. #5
    ROG Enthusiast Array sl910 PC Specs
    sl910 PC Specs
    MotherboardMaximus 13 Hero PCB 1.02
    ProcessorIntel i9 11900K
    Memory (part number)Crucial 64 GB 3200MHz (4x16GB, CL22)
    Graphics Card #1Nvidia RTX 3090 Founders Edition
    Storage #1Samsung NVMe 980 Pro 1TB
    Storage #2Samsung NVMe 970 EVO Plus 2TB
    CPU CoolerNoctua NH-D15S chromax.black
    CaseLian-Li PC-A61WX
    Power SupplySeasonic PRIME TX-1000
    Keyboard Microsoft Wired Keyboard 600
    Mouse Microsoft Clasic Intellimouse
    OS Windows 10 Pro FR 21H1

    Join Date
    Jan 2020
    Reputation
    10
    Posts
    34

    Quote Originally Posted by sl910 View Post
    @sl910, can we assume you actually updated your system? Yes of course ! No troubles. So far so good for me
    I have to say that something sounds strange for me. 0902 version is published as a regular version for the M13 hero MB. At the same time, the same version (0902) is published as a beta version for the Maximus 13 Extreme.

    Regards

    sl910

  6. #6
    ROG Enthusiast Array Grimpak PC Specs
    Grimpak PC Specs
    MotherboardROG Maximus XIII Apex
    Processori9 11900f
    Graphics Card #1Watercooled MSI Vega 64 Airboost OC
    Sound CardSteelseries GameDac
    Storage #1WD SN850 500GB
    Storage #2Raid0'ed 2xWD SN550 1TB
    CPU CoolerModified EK-MLC Phoenix + Eisbaer aurora 360
    CaseCooler Master SL600M Black Edition
    Power SupplySeasonic Focus gold 1000w
    Keyboard Steelseries Apex Pro
    Mouse Steelseries Rival 710

    Join Date
    Jun 2020
    Reputation
    10
    Posts
    52

    Quote Originally Posted by berglake View Post
    BIOS 0902 bricked my motherboard.
    Nothing happens when i press power.

    Good job Asus.
    try the flashback trick?

  7. #7
    ROG Guru: Orange Belt Array Saltgrass PC Specs
    Saltgrass PC Specs
    MotherboardMaximus XIII Hero
    Processori9 11900K
    Graphics Card #1EVGA RTX 3090 FTW
    Sound CardOn Board
    MonitorDell AW3420DW
    Storage #1Samsung 980 Pro 2 TB
    Storage #2Samsung 860 Pro 1 TB
    CPU CoolerCooler Master Hyper 212X
    CaseCooler Master
    Power SupplyAntec HCP Platinum 1000
    Keyboard ASUS Strix Flare
    Mouse ASUS Chakram
    Headset/Speakers Logitech wired 5.1
    OS Win 10 Pro
    Network RouterROG Rapture GT-AX11000/AXE11000
    Accessory #1 VR Headset
    Accessory #2 Saitek X52

    Join Date
    Jan 2014
    Reputation
    18
    Posts
    408

    I just did mine with the Bios flashback mode.. Everything seems to be operating normally. One thing I did not expect was seeing the 4 red LEDs on my video card flashing..

    What I learned and settings are just the result of going back to default settings.

    Use something with a small footprint to hold down the Bios button or you can't see when it starts flashing.

    Thunderbolt was re-enabled.

    Re-Size Bar was disabled

    OS Type was set back to Other OS.. It appears they changed the reference to the CSM and possibly it is being referred to as Standard or Custom..

    TMP setting was disabled.. Had to re-enable it under Advanced, PCH-FW PTT enabled. This might mess with folks running Win 11..

  8. #8
    New ROGer Array
    Join Date
    Feb 2021
    Reputation
    10
    Posts
    4

    Talking

    Quote Originally Posted by Grimpak View Post
    try the flashback trick?
    It worked.
    Thank you!

  9. #9
    ROG Member Array Seth Anton PC Specs
    Seth Anton PC Specs
    MotherboardASUS ROG MAXIMUS XIII HERO
    ProcessorIntel Core i9-11900K
    Memory (part number)G.Skill Ripjaws V 64GB DDR4 K2
    Graphics Card #1ASUS ROG STRIX GeForce RTX3090 GAMING OC
    MonitorAsus PG279Q ROG Swift 27-inch 165Hz
    Storage #1Samsung SSD 960 Pro M.2 512GB
    Storage #2Samsung SSD 860 EVO SATA3 1TB
    CPU CoolerCorsair Hydro Series H150i Pro AiO
    CaseObsidian Series™ 750D Full Tower ATX Case
    Power SupplyCorsair AX1200i Digital ATX 1200 Watt ATX
    Keyboard Wireless Keyboard 6000 - Microsoft
    Mouse G602 Logitech
    OS Windows 10 pro

    Join Date
    May 2018
    Reputation
    10
    Posts
    18

    Installed 0902 bios with default settings except :

    Ai overclock tuner : XMP I
    Intel Adaptive boost technology : Enabled
    ASUS Multicore Enhancement : Enabled - Remove All limits

    Everything is fine, system is ultra stable and i am reaching 5.1ghz at all cores on Cinebench R23 ( multi core stress)
    But while i was playing Microsoft Flight Simulator i was checking VCORE values which sometimes have a spike to 1.47v with a main value between 1.35 to 1.43v
    Is this normal for 11900K? V-core is at default offset mode
    thanks

  10. #10
    ROG Enthusiast Array
    Join Date
    Jun 2021
    Reputation
    10
    Posts
    38

    Hi all,

    I flashed my Maximus XIII Hero with the v0902 BIOS, from the base version from 6th of January 2021. I flashed the image from C:/ directly through the BIOS EZ Flash option, it ran thorugh, restarted a few times since it was flashing some other FWs, and then, it loaded the American megatrends screen asking me to press F1 for some auto-setup tool (probs because it reverted back to BIOS defaults) and on the very last paragraph it was saying something along the lines - standby, you're now going to be forwarded to the UEFI settings. I was pressing F1, nothing was happening, pressed F2, nothing, left it standing like that for 15minutes, smoked like 4 cigarettes during that time, nothing has happened. Had to manually shut down the PC and start it again, afterwards, everything was working like a charm.

    Very stressful though as it stopped at the American megatrends screen :'( Cigarettes helped a bit

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •