Results 1 to 9 of 9
  1. #1
    ROG Junior Member Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    3

    Nahimic services, processes causing significant slowdowns, delays WIN10

    Hi, I've googled this problem and can see it is still a problem, can someone at ASUS advise what to do? If this is going to affect my Motherboard's RGB or Audio performance then I'll just get a refund from Amazon but I want to keep it since ASUS boards are the best looking.

    Here's what happens to me:

    1. Opening any app will be delayed by about 3-4 seconds.
    2. Saving or opening a file within a app will also be delayed (the window)

    I mean, this is bad, especially when I'm trying to multi task.

    I also have an unrelated issue too, where the ASUS BIOS doesn't load at all, it skips it and goes straight to Windows, even if I hold shift to boot into BIOS. It's like BIOS has disappeared, F2, del doesn't do nothing either. I wonder if there's a button on the mobo I accidentally switched.

  2. #2
    ROG Junior Member Array
    Join Date
    Aug 2016
    Reputation
    10
    Posts
    3

    is anyone from ASUS gonna answer this. I'll get a refund through amazon then

  3. #3
    ROG Guru: Green Belt Array
    Join Date
    Feb 2019
    Reputation
    129
    Posts
    709

    Its the same across everyone's platforms. Junk bloatware. Uninstall and its all good. Its just supposed to make headphones sound better but the only thing Ive found that does this is using the Toslink out and a DAC.

    This is a user self help forum sponsored by ASUS, if you have an issue that you need them to help with its slim that you will get it posting here. Open a ticket or return your board and get an MSI of Gigabyte and have the same problem. Nahimic is not ASUS software. Find out which Realtec device you have and download the drivers from there. Tons of posts about this issue across many platforms, not just ASUS. It cam on my drivers and I disabled the service.

    It also helps when you list your specs.
    Last edited by BigJohnny; 08-10-2021 at 02:25 AM.

  4. #4
    ROG Guru: Brown Belt Array RedSector73 PC Specs
    RedSector73 PC Specs
    Laptop (Model)FA506IU-AL130T x 2
    MotherboardROG CROSSHAIR VIII HERO (WI-FI)
    ProcessorAMD Ryzen 9 3900X 12-Core Processor
    Memory (part number)4 x G.SKILL F4-3800C14D-16GTZN 14-16-16-36 Samsung B-Die
    Graphics Card #1Gigabyte Aorus RTX 2080 Ti Xtreme WaterForce (GV-N208TAORUSX W-11GC)
    Sound CardArctis DAC
    MonitorAsus ROG Swift PG348Q
    Storage #1ADATA SX8200PNP 1TB
    Storage #22 x Samsung SSD 840 EVO 250GB
    CPU CoolerCoolermaster Liquid Pro Master 360
    CaseEVGA DG-87 Gunmetal Grey Gaming Case
    Power SupplyEVGA SuperNOVA G2 750W Gold Power
    Keyboard Corsair K95 RGB Platinum
    Mouse Corsair Gaming Sabre RGB Gaming Mouse
    Headset ARCTIS Pro Wireless
    Mouse Pad Cooler Master MP750 RGB Cloth Gaming Mouse Pad Extra Large
    OS Windows 11 64bit Pro
    Network RouterPfSence Intel i5-10210U 6 Port
    Accessory #1 TP-Link Gigabit 8&6 Port Switches

    Join Date
    Apr 2018
    Reputation
    65
    Posts
    1,308

    In the bios, don't turn on fast boot, or otherwise it has the effect you are describing, unable to enter BIOS using f2 or del. This feature is only useful when you don't want users entering BIOS ie work computer or kids.
    https://www.windowscentral.com/how-e...windows-10-pcs

    If you want ASUS responce, you should use ticketed support.
    Last edited by RedSector73; 08-10-2021 at 02:30 AM.

  5. #5
    ROG Enthusiast Array
    Join Date
    May 2018
    Reputation
    36
    Posts
    45

    Quote Originally Posted by RedSector73 View Post
    In the bios, don't turn on fast boot, or otherwise it has the effect you are describing, unable to enter BIOS using f2 or del. This feature is only useful when you don't want users entering BIOS ie work computer or kids.
    https://www.windowscentral.com/how-e...windows-10-pcs

    If you want ASUS responce, you should use ticketed support.
    it's not about fastboot! i tested on/off no change.
    I can confirm the slow app loading mentioned in thread. also Nahimic-service causes various system errors.

    Audio drivers need to update
    Official drivers updated 1 year ago. currently, sonic studio does & sonic radar not working. at the moment, I use mokichu drivers, but sonic-studio-link does not work on it.

  6. #6
    ROG Guru: Brown Belt Array RedSector73 PC Specs
    RedSector73 PC Specs
    Laptop (Model)FA506IU-AL130T x 2
    MotherboardROG CROSSHAIR VIII HERO (WI-FI)
    ProcessorAMD Ryzen 9 3900X 12-Core Processor
    Memory (part number)4 x G.SKILL F4-3800C14D-16GTZN 14-16-16-36 Samsung B-Die
    Graphics Card #1Gigabyte Aorus RTX 2080 Ti Xtreme WaterForce (GV-N208TAORUSX W-11GC)
    Sound CardArctis DAC
    MonitorAsus ROG Swift PG348Q
    Storage #1ADATA SX8200PNP 1TB
    Storage #22 x Samsung SSD 840 EVO 250GB
    CPU CoolerCoolermaster Liquid Pro Master 360
    CaseEVGA DG-87 Gunmetal Grey Gaming Case
    Power SupplyEVGA SuperNOVA G2 750W Gold Power
    Keyboard Corsair K95 RGB Platinum
    Mouse Corsair Gaming Sabre RGB Gaming Mouse
    Headset ARCTIS Pro Wireless
    Mouse Pad Cooler Master MP750 RGB Cloth Gaming Mouse Pad Extra Large
    OS Windows 11 64bit Pro
    Network RouterPfSence Intel i5-10210U 6 Port
    Accessory #1 TP-Link Gigabit 8&6 Port Switches

    Join Date
    Apr 2018
    Reputation
    65
    Posts
    1,308

    Quote Originally Posted by gkhann View Post
    it's not about fastboot! i tested on/off no change.
    I can confirm the slow app loading mentioned in thread. also Nahimic-service causes various system errors.

    Audio drivers need to update
    Official drivers updated 1 year ago. currently, sonic studio does & sonic radar not working. at the moment, I use mokichu drivers, but sonic-studio-link does not work on it.
    Are you the OP ?
    How do you know what system he has or if you have the same issue as you seem to think.... not following your logic here sir ?
    Last edited by RedSector73; 08-10-2021 at 09:46 AM.

  7. #7
    New ROGer Array dragonwolf5589 PC Specs
    dragonwolf5589 PC Specs
    MotherboardAsus Maximus XII Formula
    ProcessorIntel I9-10900K
    Memory (part number)Corsair Vengeance RGB Pro 32GB (2x 16GB) CMW32GX4M2Z3200C16 3200MHz DDR4 RAM
    Graphics Card #1Zotec Nvidia GTX 1060 6GB
    MonitorAcer QG241Y
    Storage #1Samsung 970 Evo 2TB m.2 NVMe SSD
    Storage #2Samsung 860 2TB SATA SSD | Samsung 860 SATA 1TB SSD
    CPU CoolerCooler Master MasterLiquid ML240R ARGB 240mm
    CaseCoolermaster MasterCase H500 ARGB Mid-Tower
    Power SupplyCorsair CP-9020178-UK RM650x 80 PLUS Gold 650 W
    Keyboard Corsair
    Mouse Combatwing Gaming Mouse
    OS Windows 10 Pro (21H2)

    Join Date
    Jan 2021
    Reputation
    21
    Posts
    10

    Quote Originally Posted by gkhann View Post
    it's not about fastboot! i tested on/off no change.
    I can confirm the slow app loading mentioned in thread. also Nahimic-service causes various system errors.

    Audio drivers need to update
    Official drivers updated 1 year ago. currently, sonic studio does & sonic radar not working. at the moment, I use mokichu drivers, but sonic-studio-link does not work on it.
    I too use Mokichu drivers, sadly it causes blue screen unless i remove/disable Nahimic Service (and if I use the Asus Supplied Audio Drivers, i get NO sound at all!)
    It seems i just have to find an alternative "equaliser" and deem asus/realtek Nahimic to be "dead" - i never cared for radar, but sonic studio actually made my audio miles better for past 12 months.

    To the OP: I would just disable Nahimic Service - it corrupts graphics card drivers, corrupts ton of things - I no longer trust it, after 4 days googling, the only way to fix any issues is to remove it entirely.

  8. #8
    New ROGer Array dragonwolf5589 PC Specs
    dragonwolf5589 PC Specs
    MotherboardAsus Maximus XII Formula
    ProcessorIntel I9-10900K
    Memory (part number)Corsair Vengeance RGB Pro 32GB (2x 16GB) CMW32GX4M2Z3200C16 3200MHz DDR4 RAM
    Graphics Card #1Zotec Nvidia GTX 1060 6GB
    MonitorAcer QG241Y
    Storage #1Samsung 970 Evo 2TB m.2 NVMe SSD
    Storage #2Samsung 860 2TB SATA SSD | Samsung 860 SATA 1TB SSD
    CPU CoolerCooler Master MasterLiquid ML240R ARGB 240mm
    CaseCoolermaster MasterCase H500 ARGB Mid-Tower
    Power SupplyCorsair CP-9020178-UK RM650x 80 PLUS Gold 650 W
    Keyboard Corsair
    Mouse Combatwing Gaming Mouse
    OS Windows 10 Pro (21H2)

    Join Date
    Jan 2021
    Reputation
    21
    Posts
    10

    Quote Originally Posted by SID___ View Post
    is anyone from ASUS gonna answer this. I'll get a refund through amazon then
    This forum is for asus users - asus themselves dont reply through here, only via their support. Sadly many of us have been having same issues and ive reported it to asus support who at first blame it on my graphics card and then just tell me to use old drivers (which still dont work) - they then "closed" the ticket as they "could not find a solution" and then was "happy" i found a "workaround" (by typing msconfig in start menu and permanently disabled nahimic service

    If you have not get returned it for a refund, disable Nahimic Service - theres a 90% chance it will work then.

  9. #9
    ROG Member Array blukas69 PC Specs
    blukas69 PC Specs
    MotherboardMaximus Hero XIII (0402)
    Processor10900K
    Memory (part number)G.Skill Ripjaws V 32GB DDR4-3600 CL14~F4-3600C1
    Graphics Card #1GIGABYTE AORUS RTX 3080 Ti MASTER 12GB
    Sound CardMOBO
    Storage #1Firecuda 520 SSD ZP000GM30002
    Storage #2INLAND 2T
    CPU CoolerDH-15 BLACK CROMAX
    CaseASUS GT501
    Power SupplySEA SONIC 1000 PRIME TX
    OS WIN 10 PRO

    Join Date
    Mar 2021
    Reputation
    10
    Posts
    18

    Quote Originally Posted by dragonwolf5589 View Post
    This forum is for asus users - asus themselves dont reply through here, only via their support. Sadly many of us have been having same issues and ive reported it to asus support who at first blame it on my graphics card and then just tell me to use old drivers (which still dont work) - they then "closed" the ticket as they "could not find a solution" and then was "happy" i found a "workaround" (by typing msconfig in start menu and permanently disabled nahimic service

    If you have not get returned it for a refund, disable Nahimic Service - theres a 90% chance it will work then.
    I agree after 3 days of my build i figured out too. to disable and forget

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •