Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    5

    Asus crosshair hero VII no audio after latest bios(4703) update

    Hi, Audio was working fine earlier the bios update 4402. But after updating the bios to latest 4703 my motherboard audio is broken and it's not working i tried to get the audio working from windows,linux(fedora) still no audio. I can see the playback bar moving while i'm playing audio but no sound on my headphones.
    I tested my kraken x headphones with other devices, It's working so it's not the headphones/speaker problem but some problem within the motherboard itself

    HD Audio controller is enabled in bios, I tried the latest audio drivers in windows 10 and also windows 11 but still no sound.
    What do you guys suggest? Do you think my motherboard is broken?


    Thank you

  2. #2
    Moderator Array world PC Specs
    world PC Specs
    MotherboardASUS PRIME X470-PRO
    ProcessorRyzen 3600x
    Graphics Card #1ASUS ROG Strix 1080 ti
    Sound CardAune T1 DAC
    CPU CoolerThermaltake Water 2.0
    CaseJonsbo U4
    Power SupplyCooler Master V1200
    Mouse Logitech G Pro X Superlight
    Headset Sennheiser HD598

    Join Date
    Feb 2017
    Reputation
    38
    Posts
    65

    Have you tried downgrading the BIOS back to a previous version and seeing if the audio works on an older BIOS?

  3. #3
    ROG Guru: Yellow Belt Array dfaovred PC Specs
    dfaovred PC Specs
    MotherboardASUS Rog Strix Z390-F Gaming
    ProcessorIntel i9 9900K
    Memory (part number)32GB HyperX Predator RGB DDR4 3200MHz
    Graphics Card #1ASUS Rog Strix 2070 Super OC
    Storage #1Samsung 970 EVO Plus 500GB M.2 NVMe
    Storage #2Samsung 860 EVO 2TB
    CPU CoolerNZXT Kraken X52
    CaseNZXT H440
    Power SupplyCorsair HX850
    Keyboard HyperX Alloy Elite RGB
    Mouse Logitech G403
    Headset HyperX Cloud II
    Mouse Pad HyperX
    Headset/Speakers Corsair SP2500
    OS Windows 10 (2004)
    dfaovred's Avatar
    Join Date
    Jan 2016
    Reputation
    90
    Posts
    129

    Try resetting BIOS to default settings and reboot then try sound again.

  4. #4
    New ROGer Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    5

    Quote Originally Posted by dfaovred View Post
    Try resetting BIOS to default settings and reboot then try sound again.
    Hi, I had reset the bios to defaults, re-installed the drivers again to see if i'm missing out something. Still no audio
    My motherboard is out of warranty. I thought downgrading bios is not possible may lead to possible brick.

    Do you guys suggest to try downgrading my bios? is it safe? I think this is the last action i have to perform before giving it to the service centers to repair.

    Thank you.

  5. #5
    New ROGer Array
    Join Date
    Jun 2022
    Reputation
    10
    Posts
    5

    Quote Originally Posted by world View Post
    Have you tried downgrading the BIOS back to a previous version and seeing if the audio works on an older BIOS?
    No, I haven't done that yet. Do you recommend checking with downgrading my bios to previous to latest?

    Thank you.

  6. #6
    ROG Guru: Yellow Belt Array dfaovred PC Specs
    dfaovred PC Specs
    MotherboardASUS Rog Strix Z390-F Gaming
    ProcessorIntel i9 9900K
    Memory (part number)32GB HyperX Predator RGB DDR4 3200MHz
    Graphics Card #1ASUS Rog Strix 2070 Super OC
    Storage #1Samsung 970 EVO Plus 500GB M.2 NVMe
    Storage #2Samsung 860 EVO 2TB
    CPU CoolerNZXT Kraken X52
    CaseNZXT H440
    Power SupplyCorsair HX850
    Keyboard HyperX Alloy Elite RGB
    Mouse Logitech G403
    Headset HyperX Cloud II
    Mouse Pad HyperX
    Headset/Speakers Corsair SP2500
    OS Windows 10 (2004)
    dfaovred's Avatar
    Join Date
    Jan 2016
    Reputation
    90
    Posts
    129

    Quote Originally Posted by LostDecryption91 View Post
    Hi, I had reset the bios to defaults, re-installed the drivers again to see if i'm missing out something. Still no audio
    My motherboard is out of warranty. I thought downgrading bios is not possible may lead to possible brick.

    Do you guys suggest to try downgrading my bios? is it safe? I think this is the last action i have to perform before giving it to the service centers to repair.

    Thank you.
    Yes, you can downgrade no problem. It is the same process as updating.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •