Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    3

    GX502GW (2070) Absolutely horrible RMA experience what should I do now?

    Apologies in advance if this is the wrong place, please direct me to where to post if so.

    Hello, I wanted to share this as I am honestly at a loss for what to do at this point.

    I recently needed to RMA my laptop after owning it for a year. The problem was that it was randomly shutting off during normal use, typically correlated with fan speed (almost like an overheat shut down).

    After paying the diagnostic fee and sending it in, it took them a couple of weeks to give me any sort of update. Finally, in the third week they send me a quote for almost $800; but its for a new SSD. I'm confused by this, as I told them ahead of time I'd be removing my SSD before shipping as I had already identified it as working fine and not the issue (tested). I contacted them to clear it up and they then said that they would simply be replacing the main board. This took them THREE MORE WEEKS to finish.

    Finally, I get my laptop back today after six weeks of waiting. First thing I notice is there's some bad scratches on my lid now, like they really scratched it bad. Then, when reinstalling my SSDs I notice that almost all the screws are stripped and some are even the wrong length (they were correct when I sent them). Next, when turning it on and messing around a bit, I am greeted with the same random shut offs that I sent it in for in the first place. You can imagine how angry I was in that moment.

    So to recap, the repair team may have attempted to extort me over an unnecessary SSD replacement (I made it incredibly clear that I had the SSD via the checklist and a support agent and would not need that fixed), they damaged my laptop physically via the scratches and screws, and they didn't even fix the issue despite claiming to have identified it as the main board and replaced it. I am fuming after waiting so long to get my system back. I'll also mention that I was actually able to further narrow down the issue today as a GPU problem. I noticed that after switching to discrete graphics mode, the GPU temperatures will steadily rise after startup (starting in the mid 60s) all the way up to the 90s before the power cuts. This could explain it, as this GPU is rated for ~88C. Keeping it in optimus mode allows me to use it longer before the shutoff. That said, what on earth is the point of a $90 diagnostic fee if I'm doing their job for them? Also, if they replaced the main board wouldn't that have meant a new graphics card as well, since they're soldered on or am I mistaken here? If this is the case, though, that means they didn't even perform the service they claimed to...

    Just now I did a live chat with an agent to complain and see what I could do. They were incredibly rude, unresponsive, and unhelpful. They ended up just ending the chat after creating another RMA for me. They were also malicious by not expediting the shipping per my request, and listing the weight as 1lb which I don't want FedEx to charge me for. I cannot believe how horrible this person was as well as this experience as a whole. I'm hesitant to even exercise this new RMA after everything. My only hope, if something else went wrong, would be legal action so I want to be absolutely sure things will be sorted before sending them my property again.

    I realize that was a lot and I apologize, I needed vent and put this somewhere. I also wanted to ask anyone here what they think I should do? I was thinking of calling to see if someone on the phone could help better. If ASUS wanted to make this right they would simply replace my unit right away and have me ship them this one which is clearly faulty and, now, damaged by their own techs.

    Thanks for reading and any advice is appreciated.

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    344
    Posts
    8,023

    *moved to service inquiries for attention from an ASUS representative*
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    New ROGer Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    3

    Quote Originally Posted by xeromist View Post
    *moved to service inquiries for attention from an ASUS representative*
    Thank you

  4. #4
    Moderator Array
    Join Date
    Jun 2018
    Reputation
    10
    Posts
    90

    Quote Originally Posted by BibbCW6 View Post
    Apologies in advance if this is the wrong place, please direct me to where to post if so.

    Hello, I wanted to share this as I am honestly at a loss for what to do at this point.

    I recently needed to RMA my laptop after owning it for a year. The problem was that it was randomly shutting off during normal use, typically correlated with fan speed (almost like an overheat shut down).

    After paying the diagnostic fee and sending it in, it took them a couple of weeks to give me any sort of update. Finally, in the third week they send me a quote for almost $800; but its for a new SSD. I'm confused by this, as I told them ahead of time I'd be removing my SSD before shipping as I had already identified it as working fine and not the issue (tested). I contacted them to clear it up and they then said that they would simply be replacing the main board. This took them THREE MORE WEEKS to finish.

    Finally, I get my laptop back today after six weeks of waiting. First thing I notice is there's some bad scratches on my lid now, like they really scratched it bad. Then, when reinstalling my SSDs I notice that almost all the screws are stripped and some are even the wrong length (they were correct when I sent them). Next, when turning it on and messing around a bit, I am greeted with the same random shut offs that I sent it in for in the first place. You can imagine how angry I was in that moment.

    So to recap, the repair team may have attempted to extort me over an unnecessary SSD replacement (I made it incredibly clear that I had the SSD via the checklist and a support agent and would not need that fixed), they damaged my laptop physically via the scratches and screws, and they didn't even fix the issue despite claiming to have identified it as the main board and replaced it. I am fuming after waiting so long to get my system back. I'll also mention that I was actually able to further narrow down the issue today as a GPU problem. I noticed that after switching to discrete graphics mode, the GPU temperatures will steadily rise after startup (starting in the mid 60s) all the way up to the 90s before the power cuts. This could explain it, as this GPU is rated for ~88C. Keeping it in optimus mode allows me to use it longer before the shutoff. That said, what on earth is the point of a $90 diagnostic fee if I'm doing their job for them? Also, if they replaced the main board wouldn't that have meant a new graphics card as well, since they're soldered on or am I mistaken here? If this is the case, though, that means they didn't even perform the service they claimed to...

    Just now I did a live chat with an agent to complain and see what I could do. They were incredibly rude, unresponsive, and unhelpful. They ended up just ending the chat after creating another RMA for me. They were also malicious by not expediting the shipping per my request, and listing the weight as 1lb which I don't want FedEx to charge me for. I cannot believe how horrible this person was as well as this experience as a whole. I'm hesitant to even exercise this new RMA after everything. My only hope, if something else went wrong, would be legal action so I want to be absolutely sure things will be sorted before sending them my property again.

    I realize that was a lot and I apologize, I needed vent and put this somewhere. I also wanted to ask anyone here what they think I should do? I was thinking of calling to see if someone on the phone could help better. If ASUS wanted to make this right they would simply replace my unit right away and have me ship them this one which is clearly faulty and, now, damaged by their own techs.

    Thanks for reading and any advice is appreciated.

    My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. If you would allow, I would be more than glad to help provide a resolution to this case. Please email me with the below details so I can work with related personnel to get this straightened out.


    Product S/N:
    RMA #:
    Complete Shipping Address:
    Full name:
    Phone#:
    Email:

    My email is cl-adrian@asus.com.:

  5. #5
    New ROGer Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    3

    Quote Originally Posted by cl-Adrian@ROG View Post
    My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. If you would allow, I would be more than glad to help provide a resolution to this case. Please email me with the below details so I can work with related personnel to get this straightened out.


    Product S/N:
    RMA #:
    Complete Shipping Address:
    Full name:
    Phone#:
    Email:

    My email is cl-adrian@asus.com.:
    I have emailed you with the requested information.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •