Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Aug 2021

    RoG Claymore 2 - modular numpad constantly spamming an input


    I bought an Asus RoG Claymore 2 last week, noticed the number 3 key didn't work on the keypad, but later found out the number was was constantly being spammed.

    I tried to fathom why it didn't work so restarted PC, thought maybe the 3 on my Naga was being pressed and stopping it etc so eventually restarted the PC again this is when I tried to google Asus support it came out as "A3sus". This got me thinking as I didn't type number 3. So restated PC once again, tried to use google, didnt type anything only to get "3" spammed. I tried to press 3 to stop it (had similar issues in games were character would continue to walk forward from a W press when I released and would press it again to reset the input) but this didnt stop it spamming "3", I press 123 on the numpad and this gave me the input of 12 and 3 stopped spamming. This is when number 3 didnt work at all. Here is what I tried:

    - Taking the modular numpad off and installing it again causes the numpad to spam "3".
    - Using the modular keypad on the opposite side resulted in same error
    - All drivers were up to date and also firmware
    - Pressing any other key resulted in the 3 key stopping it spamming the input on screen
    - The FN key didnt work with the numpad attached, FN worked without the numpad installed
    - Tested this theory by holding H down, letting it spam in notepad and stopping it by pressing G, as I kept the H down I tried to use the FN key which didn't work.
    - This acted like my number 3 numpad issue meaning the numpad was constantly sending a signal for 3

    I tried the forums, 1 post about the volume key not working another about 2, 5,8 not working but worked the next day.

    I contacted Asus support, they responded very fast suggesting it might be a mechanical issue and to return it to place of purchase.

    I returned the keyboard for a replacement, now received a new keyboard which the same exact issue but number 5 on the keypad.

    I have tried the keyboard without armory crate, updated armory crate and even used a friends PC which has no gaming software installed and the issue persisted.

    I have determined this issue is related to either the keyboard receiving a signal when in full keyboard setup or the numpad sending a bad signal or just that specific switch has been through poor quality control and constantly activating.

    Has anyone else come across an issue like this? I really like the Claymore 2 and honestly don't think I can get my hopes up that the 3rd one won't have an issue.

    Edit- UK keyboard layout if that makes any difference
    Last edited by Shenbu245; 08-25-2021 at 06:32 PM.

  2. #2
    New ROGer Array roberthurley14 PC Specs
    roberthurley14 PC Specs
    MotherboardROG Maximus Z690 Extreme
    Processori9-12900K AlderLake
    Memory (part number)CMT32GX5M2C4800C34
    Graphics Card #1ROG STRIX RTX 3090
    MonitorROG PG279Q x2
    Storage #1Samsung 980 Pro 1TB
    Storage #2Samsung 980 Pro 2TB
    CPU CoolerNoctua NH-D15 Black
    CaseFractal Design Torrent
    Power SupplyEVGA SuperNOVA 1200 P2 PLATINUM 1200W
    Keyboard ROG CLAYMORE II
    Headset HD 6XX
    Mouse Pad Gamers Nexus
    Headset/Speakers Logitech z906
    OS Windows 11 Home 64-bit
    Network RouterASUS AX11000

    Join Date
    Mar 2020

    I have been having issues with mine though in my case it seems the Down Arrow key gets locked intermittently (on mainboard). i.e Ill be on a webpage or game and suddenly it is as if I have the down arrow key pressed hard (like sticky key). In my case the issue stops/corrects after I spam the windows key but always returns randomly. ASUS Support suggested I do a reset by holding the FN and ESC key for 10seconds, though this hasn't had any effect longterm. I am unsure if issue is software/hardware based at this point.

    Mine is also UK layout (Bought from OCuK)

  3. #3
    New ROGer Array
    Join Date
    Dec 2019

    A not perfect solution

    So I have the same problem its is definitely software related in my case the best fix I could find was I disabled the down arrow key in a profile I have set up I don't use the arrow keys so while imperfect its the best I could do!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts