Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Aug 2021

    Question Constant background processing from ASUSFramework

    For the past week I have noticed unusual behavior on my laptop. It is a Zephyrus G14 with the following specs:
    Model Number - GA401IV-BRN96

    Windows version:

    Edition: Windows 10 Home
    Version: 20H2
    OS build: 19042.1165
    Experience Windows Feature Experience Pack 120.2212.3530.0

    BIOS version - GA401V.219

    Processor - AMD Ryzen 9 4900HS

    Graphics card - NVIDIA GeForce RTX 2060 with Max-Q Design, AMD Radeon Graphics (chipset is AMD Radeon Vega)
    NVIDIA driver version -
    AMD driver version - 27.20.1020.2002

    Storage - Intel 660p NVMe PCIe M.2 1TB (953 GB, 540 GB free)

    RAM - Dual-channel DDR4-3200 SDRAM 16 GB clocked at 1600 MHz

    Touchpad - ASUS Precision Touchpad
    Driver version -

    When I leave my mouse cursor idle, I'll see it load with the smaller hourglass next to it as shown in these gifs

    I tried to see if this behavior would happen in Safe Mode but when I left my cursor alone it did not show the hourglass next to it.

    When I l restarted the computer to exit Safe Mode and logged in again I tried uninstalling and reinstalling my touchpad drivers. Then I connected a mouse to my computer. Both times I kept seeing that hourglass. Then I returned to Safe Mode again but with the mouse connected. There, the cursor did not have the hourglass popping up from time to time next to it.

    Then I restarted again to leave Safe Mode and login to my account. I ran the following commands in PowerShell as an administrator:
    DISM /Online /Cleanup-Image /RestoreHealth

    Windows did find corrupted files and fixed them but this did not fix the cursor issue. Tried scanning for malware with MalwareBytes but it did not return anything.

    Finally I got Process Explorer and looked to see if there were any processes behind the scenes that might be causing my issue. After several tries I noticed that AsusFramework would appear repeatedly then close. I'm wondering if this is related to Armoury Crate. This seemed to also happen at the same time with the cursor behavior.

    Has anyone else noticed this kind of behavior and if so how did you fix it?
    Miniatura de Adjuntos Miniatura de Adjuntos redline-3-jpg.jpg  

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts