Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Sep 2021

    MyASUS white window

    Hi, everybody! Alex here!
    I'm a proud owner of a ROG Zephyrus s17, which i personally use as an alternative mobile gaming/workstation setup since i moved temporary in Duesseldorf.

    While what concerns gaming works flawless and gives me nothing to complain about, i'm experiencing a very frustrating issue with myASUS application.
    It would be nice to have an integrated "asus" way to control battery level limits, but myASUS simply never worked.

    I launch it and loads with normal animation, then turns in a white window, which is completely useless. I've tried virtually everything to fix it, performing reinstallations with registry cleaning and so on.
    No matter which version of asus interface i have (V3 currently), it simply stays white despite of everything i tried. Up to date i haven't found a solution on the web describing my issue. There's apparently only one guy on reddit, which posted a screenshot of my exact problem but none found a solution.

    Does anyone know a solution to this or has anybody experienced the same issue? Any workaround?
    Last edited by aw4ken; 09-15-2021 at 10:25 AM. Reason: SOLVED

  2. #2
    New ROGer Array
    Join Date
    Sep 2021


    Ok, i figured it out what caused my problem.
    That's a conflict of permissions/ownership of the app executable itself.

    As long as i launched the shortcut i got from microsoft store i got the white window, and i tried then to gain permission of the executable itself, which is in the following path to be found:
    C:\Program Files\WindowsApps\B9ECED6F.ASUSPCAssistant_3.0.19. 0_x64__qmba6cd70vzyy\MyASUS

    You have to get full ownership and access to WindowsApps folder.
    Here's what's strange: when i launch the executable directly, it works. when i launch the microsoft store shortcut, i get white window.

    I simply replaced the shortcut, and it works now without problems.

    It was difficult to find a solution on the web due to the name itself "MyASUS" outputs in google thousands of useless thread. That's simply too generic.
    Winzoz works always the same way and when no other cause seems to justify a software malfunctioning, check the original path and mess with ownerships.

  3. #3
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010

    Thanks for reporting back for others that might find this.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts