Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    3

    ROG Strix Flare Play/Pause button light

    Has anyone else had the Play/Pause button light stop working? The function of the button still works but the white light behind doesnt turn on. I have tried updating the firmware but makes no difference. Possibly this is a RMA?

  2. #2
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014
    Reputation
    158
    Posts
    1,988

    Was it working before? Any idea what happened when it suddenly stopped working?
    Are you on firmware 0.00.35 / Armoury 3.00.11?
    Please check your inbox, a link to the firmware has been sent. Please update again manually if necessary.

  3. #3
    ROG Junior Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    4

    i had the same problem, r u already fix it?

  4. #4
    Administrator Array MasterC@ROG's Avatar
    Join Date
    Aug 2014
    Reputation
    158
    Posts
    1,988

    Quote Originally Posted by BaimYahya View Post
    i had the same problem, r u already fix it?
    Please check your inbox, a link to the firmware has been sent. Please update again manually if necessary.

  5. #5
    New ROGer Array
    Join Date
    Nov 2019
    Reputation
    10
    Posts
    1

    Same problem

    Please send me also the manual update for the firmware. Thanks.

  6. #6
    New ROGer Array
    Join Date
    Mar 2019
    Reputation
    10
    Posts
    2

    ROG Strix Flare Media Key RGB Lightning not working

    Mine also please send me a firmware thanks.
    Last edited by Verxsil; 02-08-2020 at 04:02 AM.

  7. #7
    New ROGer Array
    Join Date
    Dec 2019
    Reputation
    10
    Posts
    1

    same problem

    Please send it to me too, ive recently experience the same problem and now even the skip buttons are not lighting up

  8. #8
    New ROGer Array
    Join Date
    Nov 2018
    Reputation
    10
    Posts
    3

    Mine still dont work with the firmware, I tried to send me keyboard back but it got damaged in shipping to the retailer and the delivery company wont take responsibility. It still works but now has a crack in it.

  9. #9
    New ROGer Array
    Join Date
    Feb 2020
    Reputation
    10
    Posts
    1

    (Stop) and (Previous) media key lights not working

    I've got the same problem. Both the 'Stop' media button and the 'previous' media button gradually stopped working. I noticed that they got dimmer with each start up. Does the firmware help or is there another solution to this? Thanks

  10. #10
    New ROGer Array barcatanvir PC Specs
    barcatanvir PC Specs
    Laptop (Model)Asus Vivobook S433EA
    MotherboardAsus ROG Z390-F Motherboard
    ProcessorIntel Core i9 - 9900k
    Memory (part number)Gskill TridentZ RGB 32GB (3200Mhz)
    Graphics Card #1Asus ROG Strix RTX 3090
    Sound CardROG Throne Qi
    MonitorAsus TUF Gaming VG27AQL1A Monitor –27 inch
    Storage #1Samsung 970 Evo Plus - 500GB
    Storage #2Samsung 970 Evo Plus - 250GB
    CPU CoolerAsus ROG RYUJIN 2 360 AIO Liquid CPU Cooler
    CaseAsus ROG Strix Helios
    Power SupplyAsus ROG Thor 1200W Power Supply
    Keyboard Asus ROG Claymore
    Mouse Asus ROG Pugio, Asus ROG Keris Wireless
    Headset ROG Delta S, ROG Cetra
    Mouse Pad Asus ROG Sheath, Asus ROG Scabbard 2
    Headset/Speakers Sony BDV-9200W Home Theater
    OS Windows 11 Pro
    Network RouterAsus AX88U Router
    Accessory #1 ROG ARGB Strips X2
    Accessory #2 Asus ROG Riser Cable, ROG Strix Arion
    Accessory #3 Nzxt P140 x3 Fans

    Join Date
    Mar 2019
    Reputation
    10
    Posts
    3

    Angry bacckward media key is not light up

    all the buttons light up but multimedia key backward light is not working. need help.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •