Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    33
    Posts
    8

    High power consumption / ignoring of limits with bios 2423 (5900X / B550-F)

    Ever since I built this Ryzen system, the power consumption has been really high. With the newest bios 2423, the load consumption even jumped up and will ignore all limits set in bios. I'm using a Ryzen 5900X with 32GB of RAM, currently set to 3800MHz.

    For comparison, the CPU package power never goes below ~37W according to HWInfo. Under load, the CPU can hit 200W easily. I normally used the regular values for this CPU in bios (142W), but even Eco mode won't tame it.
    I've used Win10 at first, then upgraded to 11 a while ago but the issue persists.
    I'm using a CO curve set to maximum undervolting with most cores at -30 and the frequency set to +50, so the CPU will usually hit 5GHz under load.

    I can, of course, understand that this is a powerful CPU and it requires some juice to run. But why would it consume 80W while I'm surfing the web with nothing but a game client (doesn't matter which one) in the background?
    Is there any status, any tech I can check to see why the CPU is doing this?

    Any help on how to setup (and/or limit) the bios are greatly appreciated.

  2. #2
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    33
    Posts
    8

    For anyone interested:

    - I was able to fix the issue with the power limit by re-flashing the bios after re-downloading it. The upper limit is safe now and works as intended

    - by switching through the Windows power options (back and forth) the CPU will now turn itself off properly during light load, even the package will go to C6 state

    - power consumption is still high due to SOC power. From what I found this is due to the high IF & memory clocks I'm running, although the voltage I use is really low. Just by going above a certain level, the power draw jumps up by at least 10W and won't change with load.

    After all, I'm really happy with the performance under load. I'm not at all happy with the power consumption under light load though and the unnecessary complexity of the bios. Some switches can be found two or three times, don't change synchronously and often even bring trouble if you'd set something up more than once.
    For a release bios & release board, this is somehow odd to me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •