Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Sep 2020
    Reputation
    10
    Posts
    1

    One Key number 9 not working on new keyboard

    Hi
    I bought a Claymore 2 recently and have an issue where the number 9 key on the numerical pad does not work. Seems a nightmare to send it back just for this - is it likely to be a software issue?

    Keyboard Version 12.21.17
    Keypad Version 1.00.14

    any help welcome thanks

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Intel NUC laptop LAPQC71D
    MotherboardROG Crosshair VIII Dark Hero
    ProcessorAMD 5800X
    Memory (part number)32GB G.Skill Ripjaws V 3600
    Graphics Card #1ROG Strix RTX3090Ti
    Sound CardSound Blaster Z
    MonitorAORUS FV43U
    Storage #1Samsung 970 Pro 512GB
    CPU CoolerCustom loop
    CaseBeQuiet Dark Base Pro 900 V2
    Power SupplyCorsair HX1000
    Keyboard ROG Strix Flare II Animate
    Mouse ROG Chakram X
    Headset Steelseries Arctis Pro Wireless
    Mouse Pad ROG Scabbard
    Headset/Speakers Logitech z906 5.1
    Network RouterpfSense/OPNsense
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    411
    Posts
    8,441

    Doesn't sound like a software issue. You could pop the key cap off and see if anything looks wrong underneath. Maybe just some debris caught in there.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Junior Member Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    2

    i also got my new claymore 2 today... made all updates and my numpad key 9 stopped working and sometimes spams it in the text... i press it often then it stops spam but still doesnt work... for me it isnt a hardware issue.. cause at the first plug in it worked... after the update it stopped.

  4. #4
    ROG Junior Member Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    2

    and yess i also removed the keycaps and looked if the Key is stuck but nothing here... the FN Key is also not working when the Numpad is attached... dont know it if the issues where also on the Claymore 1 but maybe its only some Software Issue that the next update will fix

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •