Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Oct 2021
    Reputation
    10
    Posts
    1

    Asus GL752VW IO Board USB ports don't work

    Hi.

    I have Asus GL752VW, and my USB ports, which are located on the IO board, stopped working, but still provide an output voltage. One port stopped working 2 years ago, and the second stopped working just recently. Both ports were used with the ZOWIE EC2 mouse. At first time, I thought the cause of the issue was static electricity, but when the second USB stopped working while using my mouse, I started to feel that the problem with something else. Tried resetting CMOS/BIOS, holding the power button for 30 seconds without a battery, updating BIOS. I also bought a new IO Board for 752VW, and the USB ports are still not working.

    Does anyone have any idea what could be wrong? Motherboard? But what happened with that?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •