Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Oct 2021
    Reputation
    10
    Posts
    3

    Armoury Crate not showing settings for ROG Delta headset

    For some reason, the Armoury Crate software detects my ROG Delta headset but does not (or could not) show settings for the headset. When going to the device, Armoury Crate just shows a constant loading icon for like forever. There are also times that ROG Delta does not function (as in without sound at all) even when it is seen by Windows 10's Device Manager and can be chosen as default speaker in the computer.

    Without the Delta audio settings in Armoury Crate, the headset functions (if at all!) as an ordinary cheap headphone. My laptop where I plug in the headset and where I launched Armoury Crate from is ROG Zephyrus M16.

    Attached are screenshots of the Armoury Crate when I chose ROG Delta in the device selector. I hope someone can help me and provide solutions to fix this. Thank a lot!

    Armoury Crate information:

    Code:
    Item                       Version     
    ----                       -------     
    Armoury Crate UWP App      4.2.12.0    
    ROG Live Service           1.2.18.0    
    AURA Service (Lighting Service)  3.05.18     
    Armoury Crate service      4.2.10      
    ASUS Aac_GmAcc HAL         1.0.0.0     
    ASUS Aac_NBDT HAL          2.5.0.0     
    ASUS Keyboard HAL          1.01.44     
    ASUS MB Peripheral Products  1.0.35      
    ASUS Mouse HAL             1.2.0.16    
    AacAudioHal                1.3.32.0    
    AacDispaly                 1.1.29
    Miniatura de Adjuntos Miniatura de Adjuntos Screenshot 2021-10-20 170321.jpg  

    Screenshot 2021-10-20 170404.jpg  

    Screenshot 2021-10-20 170428.jpg  


  2. #2
    ROG Member Array
    Join Date
    Dec 2018
    Reputation
    10
    Posts
    11

    Do you have Intel Smart Sound Technology in the drive manager ?

    If yes, disable it, restart your laptop and try again.

    I'm also facing the same problem in the S17.

    But be aware that you'll loose some quality in the speakers.

    I hope ASUS will look into it one day.

  3. #3
    New ROGer Array
    Join Date
    Oct 2021
    Reputation
    10
    Posts
    3

    Thank you @lahceneamine. :-)

    Disabling Intel Smart Sound Technology did resolve the problem. The ROG Delta now uses generic drivers and all sound effects and equalizer settings in the Armoury Crate will render in the headset. In fact the ROG headset sounds way, way better when using Generic Audio Driver.

    However, disabling the Intel Smart Sound Technology also disables the built-in speakers of the ROG Zephyrus M16. It will not be detected and I see an exclamation point in the Device Manager that says "Intel DSP" something.

    If I can only grab a driver for this built-in speaker which I think is a Realtek, then I could enforce updating it to it instead of the Intel SST all-around driver. Lastly, for an expensive laptop, and expensive accessories, ASUS should have made sure that everything works. :-(
    Last edited by webbysphere; 12-01-2021 at 02:52 PM. Reason: Forgot to say thanks to the person who replied.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •