Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array
    Join Date
    Feb 2014

    Maximus XIII Extreme USB-C performance


    I'm trying to use my Oculus Quest 2 using a link cable on a USB-C port. I've tried using the ports in the back of the board as well as a port I've connected to one of the front-panel USB-C connectors. I can only get it to work on one of the USB-A ports. If I use the other ports (USB-C), I get pitifully low bandwidth (387Mbps) vs. the 2.6Gbps I get when using the USB-A port. This is the bandwidth reported by the Oculus Software's internal testing tool. Yes - I've confirmed that the only difference between one test and the other is which USB port the headset is connected to, and the results are consistent: USB-C SUCKS!!

    This makes no sense to me as the USB-C ports should grossly outperform the USB-A ports ... any ideas as to what setting(s) I might have missed in the BIOS? Any special software that needs installing? The only "unknown device" in Device Manager is a networked HP Printer that no longer has drivers compatible with this version of Windows (10, fully updated to this moment).

    Please help - I can make do with the USB-A but I refuse to believe I paid top dollar for this kind of a lemon ...


  2. #2
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40BBK2-16)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II/Azoth
    Mouse ROG Chakram X/Chakram Core/Spatha X/Harpe Ace
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL / ROG Scabbard II/Hone Ace
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013

    Hi GoatHumper,

    I don't have an Oculus Quest but I've used the Oculus Rift in the past.

    After reading your post I have two questions.

    Have you tried disabling the usb power saving feature?

    As you didn't specify what link cable you're using, this could be the problem.

    Is your link cable Oculus approved? Here is one that is.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts