Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    2

    X99 Deluxe hardware issue.Help needed.

    Hi all, i was playing Forza, and had a hard restart. When my computer reset, the PCI cards were no longer functioning. Fans do not spin up and rgb does not turn on on the video card. I even swapped the video card to my old one, maybe my new card just randomly died. But no luck. The motherboard fans and cpu fans all turn on, Could the power rails to the video card have randomly died?

    I have pulled every card and ram stick out but one. and nothing is plugged in the USB Any hep would be appreciated.

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    Feb 2019
    Reputation
    129
    Posts
    713

    What card are you using? Most have power indicators right above the power connection sockets.

  3. #3
    New ROGer Array
    Join Date
    May 2020
    Reputation
    10
    Posts
    2

    3080TI Aorus card. The lights do not turn on at all. I also switched out to an older 9 series titan X. with no luck. It was running solid up to the random hard reboot. i have a 1200 watt power supply.

  4. #4
    New ROGer Array
    Join Date
    Nov 2021
    Reputation
    10
    Posts
    33

    Do the diagnostic LED's on the motherboard give any indication of the issue?

  5. #5
    ROG Guru: White Belt Array AS185 PC Specs
    AS185 PC Specs
    Laptop (Model)Lenovo Y700-17ISK
    MotherboardZenith Extreme
    ProcessorAMD Threadripper 1950X
    Memory (part number)4 x G Skill F4-3200C16D-32GTZKW @ 3200MHz
    Graphics Card #1Nvidia Titan RTX
    Sound CardIntegrated SupremeFX
    MonitorSamsung Odyssey G5 C34
    Storage #16 x PNY 2TB XLR8 CS3030
    Storage #23 x 1TB Crucial MX500
    CPU CoolerThermaltake Water3.0 Ultimate
    CaseCorsair Obsidian 900D
    Power SupplyCooler Master MasterWatt Maker 1200W
    Keyboard Razer Ornata Chroma
    Mouse Razer Mambe TE / Logitech USB TrackMan Wheel
    Mouse Pad steelseries Cyberpunk 2077 edition
    Headset/Speakers Logitech Z-5300e
    OS Windows 10 Home x64
    Accessory #1 Asus Hyper M.2 X16 Card V2
    Accessory #2 Asus DIMM.2 card in slot
    Accessory #3 KingMod Corsair 900D Silencing Kit
    AS185's Avatar
    Join Date
    Feb 2020
    Reputation
    21
    Posts
    121

    Hey,

    I'm thinking this has something to do with the CPU lines. Which processor do you have installed? Maybe it's in-efficient for the CPU lines? I'm thinking also that 28 lines should be fine for one graphics card but this motherboard is a few years old so maybe the newer designed graphics component needs more lines to operate? This is a PCIe 3.0/2.0 motherboard so I'm not too sure also for that beast of a card you possess. Some people used to say that all PCI express slots are backwards compatible but truly I'm not too sure about that theory myself. Make sure you test the 3080Ti on a different PC.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •