Results 1 to 9 of 9
  1. #1
    ROG Member Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Question Zephyrus M15 ineradicable audio crackling on both internal and USB DAC

    Apologies for the slightly dramatic title, but this is an audio problem that seems to defy (my) comprehension. I recently purchased a Zephyrus M15 laptop (GU502LU-HN080T, i7-10750H, GTX 1660 Ti), and have been plagued with audio crackling ever since, the sort that sounds like a fireplace. The crackling is audible whether I am listening to music or playing a game, and can usually be triggered in the latter by sudden audio cues (like menu selection sounds). I listen to FLAC and sometimes SACD music using my external DAC, which would have to be set to WASAPI exclusive for the latter (DoP); and I can hear occasional crackling with that, too, though far less common (every ~5 min).

    The difficulty is that the same crackling can be heard on both the external DAC and using the internal headphone jack, which eliminates hardware problems relating to the two. Furthermore, I have tested different pairs of headphones (on different cables), eliminating the headphones as a factor. I have then proceeded to do the following in a series of maddening attempts to fix the problem:
    • BIOS reset to default settings;
    • CPU reset to stock (no undervolting/overclocking);
    • Windows high performance power plan (with Armoury Crate 'Turbo' mode);
    • Windows audio sampling settings (tested 16 bit 44.1 kHz, 24 bit 48 kHz, 24 bit 96 kHz);
    • Disabling Fastboot;
    • LatencyMon, which reports <400 μs in Turbo mode (and in which the crackling still persists);
    • Disabling all audio enhancements (a bit of a journey, I tell you): the laptop comes with Nahimic APO (Sonic Studio 3) preinstalled, a rather notoriously difficult to remove software. Even when you turn off all effects, the APO insists on affecting your audio (it makes it sound worse). Only by using the Windows device installation restrictions policy could I prevent Windows from reinstalling the drivers upon a restart, allowing me to delete whatever traces of Nahimic I could find, or at least prevent them from running. All Nahimic processes/services are disabled, the APO software device is deleted, and Windows no longer reports that there are any 'audio enhancements' available to turn on.
    • Factory reset with OEM recovery partition;
    • Factory reset with OEM recovery partition, then immediately upgrading to Windows 11;
    • Ensured all audio and Intel ISST drivers were the latest OEM, as well as updating Intel & Nvidia display drivers (apparently these can cause DPC latency?);
    • Moving music/games from HDD to SSD (no difference);
    • Setting all available devices to Message Signalled Interrupts;
    • Running TestMem5 with the 'extreme@anta777' config, and Prime95, both with no errors after 1h (the problem could still lie here, but it seems rather improbable?);
    • Turning off Game Mode and hardware-accelerated GPU scheduling.


    The one thing that seems to have reduced the severity of the popping is uninstalling Nahimic, though I have not tested whether that affected the audio on the external DAC. The other thing I would mention is that I seem to have reduced the crackling to tolerable levels in my music by setting the WASAPI event mode hardware buffer to 1000 (as high as it goes), though I am uncertain as to whether this is a placebo. At any rate, the problem is still quite noticeable when playing a range of games (from ARMA 3 to Control to Read Dead Redemption 2 to Minecraft).

    If anybody could assist me with this, you would be helping a man get to sleep at night again. Any suggestions would be absolutely welcome.
    Last edited by OldMumpsimus; 12-04-2021 at 02:00 PM.

  2. #2
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    75
    Posts
    1,961

    Hi OldMumpsimus,
    Does it also occur with internal speaker?
    If there is no audio output(no music or games), do you also hear the audio crackling?
    If you replug the USB DAC or twist the headphone jack when the audio crackling occurring, is it still audio crackling?
    May I have the following information?
    - the bios version
    - the audio driver version
    - the video or recording about the audio crackling
    - Is it win10 or win11? Have you run windows update?
    Thank you.

  3. #3
    ROG Member Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Hello STARRAIN@ROG,

    Thank you for your assistance.

    Yes, the problem also occurs with the internal speakers.
    The problem does not exist when there is no audio playing.
    The problem persists after replugging headphones / external DAC.

    The BIOS version is 312.
    The Realtek audio driver version is 6.0.9268.1, and the Intel Smart Sound Technology driver is 10.25.0.4442.
    I have uploaded recordings of the problem in a few games, here: https://drive.google.com/drive/folde...Bq?usp=sharing
    The problem persists on both Windows 10 & 11. I specifically did a clean upgrade to the latter to test the audio problem. Windows Update reports no new updates.

    Thanks again.

  4. #4
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    15
    Posts
    920

    Hi OldMumpsimus,
    Can you try one more thing?
    Can you set the laptop to "airplane mode"? like turn off all the wifi, bluetooth, Ethernet..even disconnecting the adapter
    and listen to music offline to see if it help?
    Thank you.

  5. #5
    ROG Member Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Hello Blake@ROG,

    Glad to oblige. I turned on Flight mode, and made sure that all wireless connections were turned off, and that nothing was plugged into the computer except the headphones. Unfortunately, the problem still persists.

    If you have any other suggestions, I would be grateful. If not, then I think I will consider handing it in for a warranty service.

    My many thanks.

  6. #6
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    15
    Posts
    920

    Hi OldMumpsimus,
    Can you help to record one more scenario?
    We hope to hear the crackling sound with softer music.
    (it was clearer with the gun shot video, but not the one about horse riding in the rain)
    I have been consulting more about this.
    Thank you so much.

  7. #7
    ROG Member Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    5

    Hello Blake@ROG,

    I have recorded two more scenarios in which the problem is audible, and have uploaded them to the same Google Drive folder along with a few notes: https://drive.google.com/drive/folde...Bq?usp=sharing

    The crackling is present with softer audio, but however it is much less common; I haven't had the time to record a few examples of those. I will however make sure to keep background recording on and, when I do encounter them, upload them and let you know.

    I appreciate your consulting on this.

    Edit 12/12: I have now uploaded another scenario, hopefully closer to what you are looking for: audio popping in ambient sounds.
    Last edited by OldMumpsimus; 12-12-2021 at 06:44 AM.

  8. #8
    New ROGer Array
    Join Date
    Dec 2021
    Reputation
    10
    Posts
    3

    The problem describes sounds similar to one I am experiencing on my Zephyrus GA503QC.

    It mostly manifests when working with real-time, low latency audio. This could impact anyone who uses their computer for DJing, audio production, keyboard playing, eDrums, etc.

    Randomly, sound stops for roughly 0.2 seconds, though the length varies. It is not a skip, but actually a brief freeze. I know this as when I am playing, the timing of the music suddenly changes. This pause is usually accompanied by a crackle, which has become the bane of my existence and a serious frustration with this new machine I bought primarily as a drum module and Ableton Live production.

    Like the user mentioned in the first post here, I have tried a myriad of fixes including disabling various wireless features, updating any and all windows, MyAsus and Armoury Crate drivers right up to the most recent 5.0.10.0, but today the problem persists in exactly the same way.

    i even went to the length today of Cloning the internal hard drive to an even faster SSD, but this has had zero effect to help the issue. I believe it is CPU-related.

    In terms of classic low-latency audio crackle, I am aware of this and is not the issue at hand. CPU usage as shown in Ableton Live is under or around 10% and there is none of the regular clicking associated with latency issues - this is certainly something different.

    Examples (1 noticeable pause / glitch sound in each .wav file):
    https://drive.google.com/file/d/1IYb...ew?usp=sharing
    https://drive.google.com/file/d/1_2a...ew?usp=sharing
    Last edited by kramhughes; 12-15-2021 at 02:41 PM. Reason: examples added as google drive links

  9. #9
    Moderator Array
    Join Date
    Feb 2019
    Reputation
    15
    Posts
    920

    Hello kramhughes,
    May I double confirm again if the issue only happen with "audio producing/editing" program?
    How about youtube music, or games?
    And this "freeze" happen with headset, internal speaker and wireless speaker?
    Thank you.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •