Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    7

    G752VL external HDMI and internal screen for a moment goes black...

    Hello everyone.

    So for about last 2 months external HDMI monitor and internal laptop screen randomly goes black for a moment BUT never at the same time and HDMI monitor does it more than laptop screen. I tried several gpu drivers, Windows 10 x64 Pro reinstallation, different gpu settings (3D settings vsync..., g-sync, resolution, refresh rates, ...), also random programs closing, latest Windows updates, Windows Game mode, internal screen cable recconect on laptop motherboard ... and other that I do not remember. Between black screens can be maybe 10 seconds to several minutes or even more. I Googled the isue, but did not find any usefull to me.

  2. #2
    ROG Member Array
    Join Date
    Feb 2012
    Reputation
    10
    Posts
    19

    Hi ACONetwork,

    So this sounds like the chip which controls the switching between internal and external monitors may be de-coupling from the board resulting in intermittent signal loss.
    The thought is the flow is different than the external monitor thus you see it more on HDMI and when you are using the laptop screen it is sometimes getting confused.

    I recently had a G752VW have the MiniDP and HDMI port fry (maybe the chip too?) but the USB C output as well as internal monitor still work. I went ahead and purchased a G752VSK-OC as a replacement but the old laptop still works.

    With that in mind, you can try and utilize the USB C to Display Port or USB C to HDMI to your monitor as the BUS seems to differ compared to the HDMI/DP chip.
    A more deeper dive is checking the chip (not sure which one) and seeing if any of the traces are NOT making good contact with the board. The chip very well could be going out as well (unlikely but still possible).

    Based on your comfortability in opening the laptop, you can check the chips on the right side of the board, if not then I suggest utilizing USB C in the interim and see if it decreases.

    Look forward to your response!
    Jupiter III
    Model: ASUS ROG G752VSK OC Edition
    Screen: 17.3’ 120hz TN 1080p Screen
    CPU: Intel i7-7820HK 2.9/3.9GHz.
    Memory: Kingston Fury 32 GB DDR4 3200 MHz. RAM
    Graphics: Nvidia GTX 1070 8GB GDDR5
    Storage:1TB Samsung 970 EVO PLUS NVME SSD (OS) + 500GB Samsung 960 PRO NVME SSD (Docs/Scratch Disk) + 1TB Samsung 850 EVO SSD (Torrents) + 500GB Crucial MX300 SSD (Photoshop)
    NAS (n0x): 12TB Netgear ReadyNAS 104 (3)4TB HGST RED 7200RPM 128mb cache

  3. #3
    ROG Member Array
    Join Date
    Aug 2020
    Reputation
    10
    Posts
    7

    Thank you for response, did not get notification anyone responded. From when I wrote, there was strange development. When I turn on laptop, open up a game and GPU usage is 60% and 39fps maximum for all Windows then I need to turn off the G-SYNC (laptop screen only supported) gpu usage goes to normal and same goes when I re-enable G-SYNC. Also when G-SYNC is working propertly and in some game, there is no more black screen on eather of the screens while gaming.

    I updated graphic driver (I used DDU also) about 4 weeks ago and for probably 3 weeks I did not have any G-SYNC and gpu usage issues but I do not remember if black screen issue was present then.

    I do not have posibillity right now to buy usb-c to hdmi adapter thanks anyway.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •