Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Member Array
    Join Date
    Mar 2021
    Reputation
    10
    Posts
    11

    ROG Strix X570 and Windows 11

    Hello,
    I have done a clean install of Windows 11 and found that the chipset does not install.
    i am using the AMD Chipset installer and I receive the following errors

    AMD Chipset Software Install Summary

    Name : AMD Processor Power Management Support
    Version : 7.0.4.4
    Install : Fail

    Name : AMD PCI Device Driver
    Version : 1.0.0.83
    Install : Fail


    Name : AMD PSP Driver
    Version : 5.17.0.0
    Install : Fail

    I do not show any devices not installed in device manager

    The Hardware I am using is:
    ASUS ROG Strix X570-E
    AMD 5800X CPU
    ASUS ROG 6800XT
    and Corsair Memory.

    If someone has an idea why those Chipset Drivers do not work It would help me out alot

    WAM

  2. #2
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    51
    Posts
    1,221

    Hi what_about_me,
    Have you tried AMD Chipset driver 3.10.22.706 from our support site?
    https://rog.asus.com/motherboards/ro...pdesk_download
    Thank you.

  3. #3
    ROG Member Array
    Join Date
    Mar 2021
    Reputation
    10
    Posts
    11

    Yes I have tried that version as well as the AMD Chipset version. both show the same problem

  4. #4
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    51
    Posts
    1,221

    Hi what_about_me,
    Does it occur on bios 4021 with bios all default settings?
    May I have a screenshot about the errors?
    Do you have any issues while using the pc?
    Thank you.

  5. #5
    ROG Member Array
    Join Date
    Mar 2021
    Reputation
    10
    Posts
    11

    Windows seems to be working OK. I am using Firmware 4021 but a get a Q Code of d3, I have loaded defaults with no change in the errors. I would be pulling my hair out but I have little so I am keeping that area clear of my hands.

    Also I was running windows 10 and upgraded to 11 with no problem, but as most windows computers it started to fill it self with Crap, so a fresh install on windows 11 and this is where I am now.

  6. #6
    New ROGer Array Ace21 PC Specs
    Ace21 PC Specs
    MotherboardROG Strix X570E Gaming
    ProcessorRyzen 5 5600x
    Memory (part number)CMW16GX4M2C3200C16
    Graphics Card #1ASUS R9280X-DC2T-3GD5-V2
    MonitorDell S2721DS & S2421HS
    Storage #1500GB Samsung 980 PRO M.2 NVMe
    Storage #2250GB Samsung 850 Evo + 5 others
    CPU CoolerCorsair iCUE H115i Elite CAPELLIX
    CaseCorsair Obsidian 750D
    Power SupplyCorsair RM750x
    Keyboard Logiteck K800
    Mouse Logitech MX Master 3
    Headset Bose QC35 II
    Mouse Pad Generic
    Headset/Speakers Altec Lansing 621
    OS W11 Pro
    Network RouterArcher VR1600v

    Join Date
    Jun 2021
    Reputation
    10
    Posts
    2

    Sounds super frustrating. I hear that Windows 10 drivers will work with Windows 11. Maybe try installing an older windows 10 driver. I know it's not ideal but at least you might get closer to diagnosing the issue.

  7. #7
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    51
    Posts
    1,221

    Hi what_about_me,
    Do you also get a Q Code of d3 with AMD Chipset driver 3.10.22.706?
    Does the install fail error appear when install AMD Chipset driver V3.08.06.148 from our support site?
    May I have the following information?
    - the serial number of the motherboard and the graphics card via PM
    - the brand and the model name of PSU and the hard drive with OS
    - Please check the specific model name of the RAM such as CMK16GX4M4A2133C13 (Ver5.29)
    - OS build such as 22000.434
    - a screenshot of the install fail error with AMD Chipset driver 3.10.22.706
    Thank you.

  8. #8
    ROG Member Array
    Join Date
    Mar 2021
    Reputation
    10
    Posts
    11

    have tried with the Windows 10 Chipset, but found it was exactly the same at the windows 11 version,
    I get the q code before installation of the chipset drivers.
    Sorry I can not find the serial number for the Mainboard or graphic card, But both are from ASUS, I use the ROG Strix X570E Mainboard and a ROG Strix LC-6800XT Gaming Graphics card.
    Now I am getting to the sad point, I use a ROG Strix 850 PSU.
    I have changed the memory for some CMK32GX4M2D3600C18 Memory from Corsair its there Vengeance LPX memory.
    I am using that version of Windows OS Build (22000.434)
    the only version of Chipset Driver I am using is 3.10.08.506 direct from AMD
    and you have seen the output of that in the first post.

    Sorry to take so long to get back but I have been busy.

  9. #9
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    51
    Posts
    1,221

    Hi what_about_me,
    Did you get Q Code of d3 right after updated to bios 4021?
    You said have tried AMD Chipset driver 3.10.22.706 from our support site and it showed the same problem.
    I'm not sure if there is any misunderstanding. To make sure compatibility, we suggest use the validated drivers from our support site.
    When you uninstall AMD Chipset driver 3.10.08.506 and install 3.10.22.706 from our support site, did it show error in the AMD Chipset installer? May I have the video of the procedure?
    Please refer to the following link to check the serial number of the motherboard and the graphics card and share me the serial number via PM.
    https://www.asus.com/support/article/566
    Thank you so much.

  10. #10
    ROG Member Array
    Join Date
    Mar 2021
    Reputation
    10
    Posts
    11

    Well I feel pretty dumb here, the Asus Chipset fixed every thing.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •