Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    2

    Issues with 3rd monitor on Ubuntu 21.10, on ASUS ROG Strix gaming laptop

    i have this problem: i can see a 2nd monitor just fine, if it's plugged into the HDMI port on my ASUS laptop. however, i really need a 3rd monitor (ie: two external monitors) for what i am doing, and from what i can see, Ubuntu itself does support that!

    here's what i am running:

    ASUS ROG Strix G513IC

    AMD® Ryzen 7 4800h

    Ubuntu 21.10

    Linux Kernel 5.13.0-23-generic

    Nvidia driver version 470

    i bought an adapter (https://www.primecables.ca/p-386453-...-support-1080p) so that my USB-C display port is converted to VGA, and have tried two different monitors connected to it, and it doesn't work. the monitor just acts like "no signal".

    and yet, in the 'display settings' config can see that Ubuntu thinks there MIGHT be a 3rd monitor, but when i try to 'apply' a setting where that monitor is marked as 'on', it just reverts back to two again (ie: it turns off the 'on switch' for the 3rd monitor automatically, probably because it can't find the monitor, or can't configure it properly).

    i am aware of some of these possible fixes that others have posted:

    https://www.reddit.com/r/ZephyrusG14...t_under_linux/

    https://askubuntu.com/questions/1244...h-20-04-on-lap

    https://askubuntu.com/questions/1230...second-monitor

    however, these (and similar articles) don't help in my case because:

    - there's no problems with running the laptop monitor and one external monitor

    - i have no xorg.conf file

    - i have no nvidia-kms file

    - i don't think 'power saving' aspect mentioned in some of those fixes is applicable, i have been testing when the monitors weren't blanked by the power saving mode, and my power mode is set to 'Balanced Power', not 'Power Saver'.

    i changed nvidia drivers from version 470 to 495 just recently, to see if that would fix it. nothing else seemed to break, but the monitor issue remained the same.

    any ideas?

    is the most likely culprit the adaptor itself? i know it was a fairly cheap one, and i have also read that the exact model/specs of a displayport adaptor can affect whether a 2nd or 3rd monitor will work on ubuntu....

    also, suggestions of "running the dGPU as main gpu" (see https://lab.retarded.farm/zappel/asu...dware/Graphics ) - is that my only option left to try? is that even safe? ;-)

  2. #2
    New ROGer Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    1

    Just to add a few data points in case they help you...

    I just installed Ubuntu 21.10 on a ASUS ROG Strix G15 Advantage Edition laptop (Rzyen 9 5900HX + Radeon RX 6800M gpu), so obviously that differs from your Nvidia gpu and not sure how much of my experience applies to your problem. But a few more data points in case they're helpful as you're trying to figure this out...

    - The 21.10 install "Just Worked(tm)" and actually surprised me after 20+ years of fighting with Linux installs especially on new-ish laptops. This was amazingly nice. And then-- ironically, accidentally-- I grabbed a USB-C hub-adapter from my old Zenbook laptop to simplify keyboard, mouse, headset, etc "docking" at my desk, without even remembering that there was a third monitor already plugged into the HDMI port on the adapter... Shocked when the monitor just powered on as a third monitor in 21.10 !!

    - Btw, this is the old Anker adapter I'd bought in 2019, the one that Ubuntu 21.10 just found and used without any hacks required. Amazon says it's no longer available but newer Anker adapters probably work similarly? Not sure. https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

    - So "Just Works(tm)" is mostly true, with 1080p laptop screen + Dell 4K monitor + Asus ProArt 1080x1200 monitor (as the third screen)... but I guess Ubuntu isn't using the dGPU unless I right-click and choose "Launch using Dedicated Graphics Card" for each app... I only tried that with the Alacritty terminal app, which supposedly supports OpenGL and gpu-acceleration... but *wow* did that break the third monitor when I dragged the Alacritty terminal to that screen. Pixelation, desktop not redrawing correctly, then when trying a long listing, just completely mangled to where it clicked to black (wrong refresh rate somehow?) and not even power-cycling brought it back. A full shut-down of the monitor AND LAPTOP and everything a couple hours later finally got it working again. Honestly thought it had physically killed the monitor hardware for a while there but I guess not. Haven't tried anything with the gpu in Ubuntu since.

    - Even in normal, non-dGPU use, there are occasional screen flickers (every few days maybe). Maybe when I'm really taxing the screen redraws or something. I already tried disabling FreeSync on the main laptop screen, especially since the other two monitors don't support FreeSync, which probably helped but not sure.

    Anyway, so even beyond the Nvidia vs AMD gpu difference, I guess the point is, the adapter above works with Ubuntu, but there might be some issues running it without the dGPU depending on which monitors (especially which resolutions) you have on the three screens.
    Last edited by jstanforth; 02-08-2022 at 01:02 AM.

  3. #3
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    2

    nice!

    @Jstanforth - THANKS for the intel, it's going to take me a while to fully unpack this (that's why i haven't answered yet) but it's a relief to know that 21.10 on an ASUS ROG does not automatically mean "i am screwed", it sure sounds like a 3rd monitor is possible

    note: the problem is most likely not my USB-C to VGA adapter... i also tried a more expensive one (https://www.londondrugs.com/targus-u.../L1063945.html) and it did the same thing, in fact that one didn't even show a third monitor as an option (and then refuse to enable it) the way my cheaper adapter did (see my original post). more importantly, i tested BOTH adapters on my brother's Windows box and they both worked "as advertised". also, the results i get from "xrandr", "xrandr --listproviders" and "lspci | grep VGA" with the Targus are same/similar as the cheap adapter. my conclusion is that it's not the hardware at fault.

    a few QUICK questions if i may, proper response later :-)

    - are you running Gnome Flashback/Metacity, or Gnome Classic, or Unity?

    - when you say you see a place to right-click on the app and tell it whether or not to use the GPU (which might be a Radeon thing only, and/or might not work on Gnome Flashback, which is what i normally use)... do you mean just literally looking at the properties of the app launcher, and a checkbox can tell it to use GPU? that would be VERY handy but i can't seem to find such a switch on my setup?

    (getting the third monitor working, and using GPU on certain apps, are indeed two different questions i know, but they are both issues i am facing and your post gave me some fresh ideas about both of them. thanks again!)

    - have you seen this cute rendering of the Impish Indri? (and other ubuntu animals? ) https://www.deviantart.com/sylviarit...ndri-891364196 LOL

    cheers,
    Fish

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •