Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    2

    ASUS TUF GAMING B550M-Plus motherboard not posting

    Just got this motherboard and a new

    Ryzen 5 5600G CPU

    Ram is 1 stick of

    G.Skill Aegis DDR4 3200MHz PC4-25600 CL16.

    PSU is Corsair 650w

    Everything turns on but it doesn't display on screen I've tried to ez flash the bios and move the memory around.

    Q-LED lights
    So there's 4 Lights Boot VGA CPU and Dram.

    With nothing plugged in but the CPU an PSU after about 30 seconds the only light that comes on is the DRAM it will pulse a couple times then off for about 15 seconds then pulse and continue this.

    With the Memory added still the only light to come on is the DRAM but this time it comes on sooner and flickers more frequently.



    None of the other lights have come on at any of these times even plugging into monitor.

    I was told on another forum more of these should be coming on an perhaps I have a bad motherboard or CPU.
    All three CPU Motherboard and Ram are new so I don't know.

  2. #2
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    51
    Posts
    1,239

    Hi Brucebwp2,
    Do you mean only DRAM qled always flickers and no display?
    Please refer to the following links to check if your RAM is in our qvl list and install in DIMM_B2.
    https://www.asus.com/Motherboards-Co...sk_QVL_Memory/
    https://dlcdnets.asus.com/pub/ASUS/m..._UM_v2_WEB.pdf
    Also, Ryzen 5 5600G CPU is validated since bios 1401. Please refer to the link below to update bios to 1401 or the latest one via USB bios flashback.
    https://www.asus.com/support/FAQ/1038568/
    Thank you.

  3. #3
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    2

    Quote Originally Posted by STARRAIN@ROG View Post
    Hi Brucebwp2,
    Do you mean only DRAM qled always flickers and no display?
    Please refer to the following links to check if your RAM is in our qvl list and install in DIMM_B2.
    https://www.asus.com/Motherboards-Co...sk_QVL_Memory/
    https://dlcdnets.asus.com/pub/ASUS/m..._UM_v2_WEB.pdf
    Also, Ryzen 5 5600G CPU is validated since bios 1401. Please refer to the link below to update bios to 1401 or the latest one via USB bios flashback.
    https://www.asus.com/support/FAQ/1038568/
    Thank you.
    Yes that's what I mean. The ram is on the list of compatible ram also.
    Was told elsewhere that it sounds like bad ram, motherboard or CPU.

    Gonna try to buy other ram to rule that out.

  4. #4
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    367
    Posts
    8,338

    Also pull the CPU and check for bent pins or debris
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  5. #5
    Moderator Array
    Join Date
    Apr 2019
    Reputation
    51
    Posts
    1,239

    Hi Brucebwp2,
    Please also refer to the following link for CPU and DRAM part.
    https://www.asus.com/support/FAQ/1042678/
    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •