Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Nov 2017

    ASUS Zenith Extreme WHEA 17 errors on Windows 11

    My main PC has 1950X and my motherboard is the ASUS Zenith Extreme. I wanted to upgrade to Windows 11 as I liked the design more, even though it is an unsupported CPU. After I upgraded to Windows 11 everything seemed normal, every program I tried was operating fine but eventually my computer froze. Nothing was responding, not my mouse, keyboard, anything. Even the small screen on the motherboard which shows the temperature froze.

    I have encountered the freezing problem multiple times, but it is a random event. So my computer may freeze after booting to Windows, sometimes while I am browsing the Internet etc. The error I am getting is the following:

    A corrected hardware error has occurred.
    Component: PCI Express Root Port
    Error Source: Advanced Error Reporting (PCI Express)
    Primary Bus:Device:Function: 0x0:0x1:0x1
    Secondary Bus:Device:Function: 0x0:0x0:0x0
    Primary Device Name:PCI\VEN_1022&DEV_1453&SUBSYS_87611043&REV_00
    Secondary Device Name:
    I have tried everything I can think in order to fix this problem. I have updated to the latest BIOS, updated to the latest chipset drivers, checked every RAM stick separately, removing the NVMe drive, installing Windows 11 to another drive, changing power profiles etc. Sometimes the errors may stop occurring, but after turning off my PC completely and turning it on again (not restarting), the errors come back.

    The only time I was able to stop the WHEA 17 messages was when I disabled the PCI Express Root Port in device manager, but this is not an ideal solution. As a note, the PCI Express Root Port which causes the problem is the one with AMD PCI, AMD PSP and USB 3.0 drivers.

    In order to use this computer I have installed Windows 10 (temporarily?) on a different drive, as I am not getting any errors in Windows 10 and the system seems stable as I didn't have any freezing problems since.

    However, I would like to have my Windows 11 install fixed and if this is not possible, I will move to Linux.

    Does anyone have any ideas on how to fix the Whea 17 errors?

  2. #2
    New ROGer Array
    Join Date
    Aug 2019

    I have exactly the same problem
    In addition to those messages, my onboard Bluetooth not working. I see some correlation there ... for the rest , my system is stable

  3. #3
    New ROGer Array SkullyNib PC Specs
    SkullyNib PC Specs
    MotherboardASUS Zenith Extreme
    ProcessorThreadripper 2950X
    Memory (part number)G.Skill F4-3200C14Q-32GTZRX
    Graphics Card #1Radeon RX 6900 XT
    Sound CardTC-Helicon GoXLR
    MonitorLG 27GN950
    Storage #1Samsung 970 Pro 1TB
    Storage #2Samsung 850 Pro 1TB
    CPU CoolerEK-Quantum Velocity sTR4
    CaseCorsair Obsidian 1000D
    Power SupplySeasonic Prime Ultra Titanium 1300W
    Keyboard Logitech G513
    Mouse Logitech G502
    Headset 1MORE Quad
    Mouse Pad Logitech G840
    OS Win 11 Pro

    Join Date
    Feb 2022

    Same WHEA 17 error problem, except no freezing.

    System is fully stable in Win11 (since mid November) except from a random tiny stutter twice a day or so (probably because of the thousands of WHEA 17 errors).

    Click image for larger version. 

Name:	WHEA17_1.jpg 
Views:	0 
Size:	118.0 KB 
ID:	92035

    Click image for larger version. 

Name:	WHEA17_2.jpg 
Views:	0 
Size:	46.4 KB 
ID:	92036

    I tried everything (like OP) to fix it and I do believe it's a straight up BIOS problem and we need a new "W11 BIOS" because this current one is broken (when combined with Win11).
    It looks exactly like the WHEA 17 problem some Alder Lake motherboards (See here and here) had with Win11 and that problem got fixed with a new BIOS. I don't believe any amount of messing around on our side can fix our current problem.

    So, ASUS, the ball is in your court. Fix this BIOS please.

    Somebody suggested it might be TPM and/or Secure Boot related. So I turned off both but the WHEA17 spamming keeps going. So it's not that either (for me).
    Last edited by SkullyNib; 02-12-2022 at 08:55 PM. Reason: addition

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts