Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    13

    ASUS G15 - Turbine Fan hopelessness

    Hey there,

    First of all thanks to everybody who will take the time to read me and try to help me.



    I'm coming to this forum after two months of owning a G15 and trying to fix an issue I'm stuck with. I've read everything I could find on Internet to fix my problem, and I'm really desperate.

    I would have RMA if I could, but I bought my laptop in Asia, where I live, and apparently I've been sold a laptop from America, which I didn't know beforehand. It does mean that my warranty is only available in the US. I contacted Asus to show me a bit of humanity as I believe it's not fair, I spent all my savings into this laptop, but it's not working properly. They didn't show just even a bit of humanity and understanding.

    Coming down to the problem itself now, basically my laptop, when doing something GPU intensive, would goes full speed on fans (6800RPM) and games would stutter, making them impossible to play. If I'm going back to the desktop, the problem remains and the only way to fix the issue is to shut down and restart the laptop.

    The problem would appear 9 times out of 10, and if I'm lucky then finally I can play properly without fans going crazy.

    These are the things I've tried so far :

    - Update bios (413)
    - Disable turbo boost
    - Limit CPU min state / max state to 95%
    - Update everything through Windows, Armoury Crate, MyAsus.
    - Reset Windows (keep files)
    - Reset Winndows (erase everything)
    - Try Windows Power Mode


    And voilà, here I lay stuck with this problem. I've noticed that the problem is less frequent if I uninstall Armoury crate, and Geforce Experience, but temperatures would go higher and performance don't seem optimal.

    I beg someone to please help with this, I would hate myself spending so much money on something that doesn't work as intended.

    Thank you

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Intel NUC laptop LAPQC71D
    MotherboardROG Crosshair VIII Dark Hero
    ProcessorAMD 5800X
    Memory (part number)32GB G.Skill Ripjaws V 3600
    Graphics Card #1ROG Strix RTX3090Ti
    Sound CardSound Blaster Z
    MonitorAORUS FV43U
    Storage #1Samsung 970 Pro 512GB
    CPU CoolerCustom loop
    CaseBeQuiet Dark Base Pro 900 V2
    Power SupplyCorsair HX1000
    Keyboard ROG Strix Flare II Animate
    Mouse ROG Chakram X
    Headset Steelseries Arctis Pro Wireless
    Mouse Pad ROG Scabbard
    Headset/Speakers Logitech z906 5.1
    Network RouterpfSense/OPNsense
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    411
    Posts
    8,476

    What kind of temps are you seeing? If it's actually getting very hot and throttling heavily it could indicate a physical problem with the cooling. Do you know if this was supposedly a brand new machine or open box? If someone else tampered with it or returned it as defective an inspection of the system would be in order. It could be as simple as a poor thermal paste application or the cooler not being seated properly. I've purchase used/open items in the past and found the previous person actually failed to reinstall a screw and was getting thermal issues.

    For Armoury crate there should be an Uninstaller on the product page for your machine. If you use that it should allow you to clean up an old install and get a fresh start.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    13

    Thanks for your answer!

    I just boot up the laptop now, temperature is 65 degrees, 2200 rpm. Everything is normal so far.
    When I launch a game, temps goes between 80 and 90 degrees, and the fan will start going crazy.
    I'm monitoring through Armourcrate, but I will download HWinfo to inspect further on those when the probem occur.

    As far as I know, it's a brand new machine. Everything was sealed when I got it.
    Poor thermal paste appliance and bad seating of the cooler is the only thing I haven't tried and maybe it indeed is the solution. But I admit I'm scared to void my -even useless- warranty.

    I tried a clean uninstall and install of Armoury Crate in the past too. Downloaded everything via Asus Website. No luck on this part.
    Is there any substitute for Amoury Crate to at least control fans profile?

    Another information, I recall that when I reset my laptop with a new windows, problem start appearign when I clicked on the Nvidia logo in the minimized tray task, it kinda downloaded/updated something and boom the problem started on its own when this was done.

    My laptop was delivered with windows 10, but if i fresh reset it lead me to windows 11. Any way to go back to Windows 10 to try my luck?

    Thanks again for your time

  4. #4
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    13

    I have some new informations.

    After checking the sensor on HWInfo, when the laptop has the problem with the fans, Thermal Throttling are in YES state, in red color (HTC and PRO SHOT EXT)
    Also I realized in normal state my CPU is around 3500 Hz, but when the problem occurs it becomes very unstable, and goes anywhere between 300hz and 2500hz (usage 2%, 41 degrees, 718mv voltage)

    Note : on the second try, it's not playing a game who triggered the problem, but simply launching HWinfo
    Last edited by zaklovesyou; 02-04-2022 at 01:13 PM.

  5. #5
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Intel NUC laptop LAPQC71D
    MotherboardROG Crosshair VIII Dark Hero
    ProcessorAMD 5800X
    Memory (part number)32GB G.Skill Ripjaws V 3600
    Graphics Card #1ROG Strix RTX3090Ti
    Sound CardSound Blaster Z
    MonitorAORUS FV43U
    Storage #1Samsung 970 Pro 512GB
    CPU CoolerCustom loop
    CaseBeQuiet Dark Base Pro 900 V2
    Power SupplyCorsair HX1000
    Keyboard ROG Strix Flare II Animate
    Mouse ROG Chakram X
    Headset Steelseries Arctis Pro Wireless
    Mouse Pad ROG Scabbard
    Headset/Speakers Logitech z906 5.1
    Network RouterpfSense/OPNsense
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    411
    Posts
    8,476

    Opening the GPU control panel shouldn't cause any issue. It could be that immediately after your Windows install it did not have a GPU driver installed and was just using a basic Windows driver. If you started having issues after a GPU driver was installed that would certainly be a clue.

    Since I don't own one of these machines I'm limited as to what I know but I can say that it's not completely unusual for modern laptops to reach 90 degrees during heavy loads. Modern designs use maximum cooling and let the CPU & GPU throttle themselves to achieve maximum performance. This means things do run hotter than a laptop 5 years ago. However, if you are getting significant throttling AND getting 90 degree temps at the same time then that means the cooling isn't doing its job.
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  6. #6
    Moderator Array
    Join Date
    Jul 2018
    Reputation
    11
    Posts
    88

    Hello Zaklovesyou
    Good day. Could you provide full model name? I am tring to find some solution for you.
    By the way, if your warranty is by USA. Is it possible send back to other friends or anyplace in USA
    , I can inform local team to deal with it . Thank you.

  7. #7
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    13

    I have a dream

    Quote Originally Posted by Alvez@ROG View Post
    Hello Zaklovesyou
    Good day. Could you provide full model name? I am tring to find some solution for you.
    By the way, if your warranty is by USA. Is it possible send back to other friends or anyplace in USA
    , I can inform local team to deal with it . Thank you.


    Hey Alvez@ROG,

    Thanks for your reply. I see a bit of hope hehe.

    The model is the GA503QR on bios 413.
    It would be lovely if my warranty work here in Asia, I know nobody in the USA and the process will take months I believe (between sending/repairing/receiving). My one and only wish would be a transfer of my warranty from US to Asia. Otherwise I believe I have to make my laptop repaired here in Asia, and I have been told by the service that would void my warranty.

    Those last days, I've uninstalled Geforce Experience, let my Nvidia drivers to an old version (496.49) , Armoury Crate uninstalled, and I'm "spamming" installing and uninstalling Radeon Software, it gives me a few days of slack before the problem comes back. But you understand it's not suitable on the long term.

    If you ever have something that would help, or more questions so you can pinpoint the problem more easily, then please feel free.

    I'm dreaming of fixing this!
    Thanks a lot Alvez

  8. #8
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    13

    Additional info :
    I noticed when the problem occurs that in MyAsus, in the diagnostic part, the temperature switch between 115 degrees and 35 degrees. But in other software such as Argus Monitor, CPU temps are normal.

    Here's the video of MyAsus report : https://www.youtube.com/watch?v=vtB_uJD8h0Y

  9. #9
    Moderator Array
    Join Date
    Jul 2018
    Reputation
    11
    Posts
    88

    Hello zaklovesyou
    I separate two parts to consider your situation by hardware and software. This model use normal thermal grease not metal liquid, so thermal reason should be
    excluded by shipping issue. In order not to voild your warranty ,I would provide software solution first. As we know this model controlled by AMD CPU bundled with Nvidia
    GPU. Instead of updating Nvidia driver no matter you donwgrade or upgrade , I will look into the other direction from AMD driver. Could you also try to update AMD graphic driver V27.20.14044.2001 and AMD chipset driver to V1.2.0.118. Than update Nvidia control panel in MS store. I need you to set your nVidia card as default display for your any software will use graphic card.Refer to this video :https://www.youtube.com/watch?v=YCqW_5HI_v4
    All the driver version I provide is for Win10. So please downgrade to Win 10 to test it. Refer to this video:https://www.youtube.com/watch?v=BO5AdG63hC0
    When I check your MyASUS video, I thought there is a possible reason that high loading software access by AMD graphic card not Nvidia graphic card.
    Do you play game or any software to stress GPU? Please provide the software name , and also please pm me your serial number , I will check warranty to see
    more detail, thank you.

    remind: My ASUS new version is V3.1.0.0

  10. #10
    New ROGer Array
    Join Date
    Jan 2022
    Reputation
    10
    Posts
    13

    Answer

    Thanks for your answer. I will follow the steps you gave me and let you know, but my question is : how can I provide myself with those old AMD drivers versions? On the official AMD website I only find new ones. And on laptopdriverslib.com I can't find the exact versions you're asking for.

    I do play a lot of games : Apex, Battlefield V, Back 4 Blood, SIFU... all of them on ultra. 3D Rendering is done properly, but when the problem occurs there are some small/medium stuttering making the game unplayable.
    I want to add that the problem can happen outside of Games, simply by running Microsoft Edge for example. If I'm lucky after 10 reboot, the problem disappear and I can use the laptop normally. I've also got rid of Armoury Crate by the way because I felt the problem was lessen without it. Do you advice putting it back?

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •