Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    16

    Angry Pugio II Wireless trouble

    Hi, my new Pugio II have a relly poor wifi connection, even if I turned off my internal 2,4G WIFI, the connection isn't strong and, as a result, the mouse on the screen and during the games is erratic.
    That is'nt accetable by a so expensive mouse.
    Anyone have a similar problem?

  2. #2
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    398
    Posts
    17,536

    Hi laoanjin,

    How far away is your pc, five or ten feet away should give a good strong connection.

    Some suggestions...

    Update windows and all drivers.

    Check device manager for any missing drivers.

    Do you have Armoury Crate installed and updated? A firmware update might solve the issue.

    Connect Your ROG Pugio II with the cable to a motherboard usb port, connect the wireless dongle to a motherboard usb port, turn the wireless switch on the ROG Pugio II to On - 2.4GHz RF Wireless mode (not bluetooth), this should get your ROG Pugio II to update.

    Click the pic to make it bigger
    Click image for larger version. 

Name:	ac.png 
Views:	0 
Size:	636.5 KB 
ID:	92103

  3. #3
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    16

    Wow, thank you Nate152 for your quick response!!!

    In the picture you can see my computer (Rog Strix 15 G532LWS) with my pugio II....the distance is in order of inches, not feet
    About Armoury crate it is updated, and also the pugio's firmware, see the attached pics...
    Any suggestion?
    Thank you very much in advance
    Miniatura de Adjuntos Miniatura de Adjuntos IMG_20220210_162007.jpg  

    armoury pugio firm.jpg  

    armoury pugio firm 2.jpg  


  4. #4
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    398
    Posts
    17,536

    You're welcome, thank you for the screenshots.

    All looks good in Armoury Crate and you should be getting good connection wired or wireless.

    Since you say the mouse is acting erratic, what are you using for a mouse pad? Would you have a couple different ones to try? If not, a hard flat surface like a cardboard box would work well for a test.

  5. #5
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    16

    Generally I use it on an hard table, not on the bed... ...my old cheap wireless mouse haven't any trouble to work smooth and fine on the table, and, why not, also on the bed... ... pugio is working fine by bluetooh and by cable. Wifi connection is the problem, so I turned off my local 2.4G wifi and Im working only with my 5G wifi, but I cannot see any improvement: I don't know what to try Any help is welcome, thx

  6. #6
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    398
    Posts
    17,536

    All right,

    Possible another wireless device somewhere is interfering.

    You could try these settings to see if they help.

    These are found in "Power Options"

    Click image for larger version. 

Name:	wadsettings.png 
Views:	0 
Size:	13.6 KB 
ID:	92116
    Click image for larger version. 

Name:	usb suspend.png 
Views:	0 
Size:	13.8 KB 
ID:	92117


    If this doesn't work, can you try your ROG Pugio II in another pc to see if the problem remains?

  7. #7
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    16

    Thank you again for your kind reply....now the situation is: in windows 11 there aren't so much options...and I've tryied my pugio on another notebook: same results.... ...I will test it also wednesday in my office in order to understand if a different environment comes different actings...more than this I cannot imagine
    I will keep you in touch after the wedsnesday test.
    Thank you
    Miniatura de Adjuntos Miniatura de Adjuntos power opt.jpg  


  8. #8
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    398
    Posts
    17,536

    That sounds like a great idea, this could help determine if there is a...

    1) Software conflict
    2) Wireless interference from another device
    3) Faulty mouse

    Maybe something as simple as unpairing and pairing it would solve the issue.

    Looking forward to your test results.

  9. #9
    New ROGer Array
    Join Date
    Jul 2021
    Reputation
    10
    Posts
    16

    Ok, It's official: I'm sad.
    I think I win a defective mouse, because: in my home I have the erratic movement of the mouse in 2 different laptops, but the environment don't change, so i tried the mouse on the second laptop at my workplace...it's the same like at my house. I tried the mouse also on a third laptop, at work, with the same results. By cable or by bluetooth it works like a charm...so...I think I have to call the service....I'm sad...

  10. #10
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Strix Z690-F Gaming WiFi
    Processori7-12700KF
    Memory (part number)Kingston Fury Beast 16GB (2x8GB) 6000MT/s (KF560C40B)
    Graphics Card #1ROG Strix 3090 Ti LC OC
    Sound CardROG SupremeFX
    MonitorHP ZR30w
    Storage #1Seagate Firecuda 530 1TB
    CPU CoolerEK Quantum Velocity2
    CaseThermaltake Tower 900
    Power SupplyEVGA Supernova 1600 T2
    Keyboard ROG Falchion NX / Strix Flare II
    Mouse ROG Chakram X/Chakram Core/Spatha X
    Headset ROG Delta S Animate
    Mouse Pad Steelseries Prism XL + ROG Scabbard II
    OS Windows 11 Home
    Accessory #1 2x Swiftech Maelstrom X300 D5 V2
    Accessory #2 2x Hardware Labs SR2 560 MP radiators
    Accessory #3 Lamptron FC-5 V3 fan controller
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    398
    Posts
    17,536

    I think testing on three different pc's would pretty much confirm a faulty mouse.

    I would do the same, contact ASUS and set up an RMA.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •