Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 35
  1. #1
    ROG Member Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    8

    Exclamation Armoury Crate and Asus Tuf Gaming K7 Turkish Q keyboard problem

    I updated the Armoury Crate and the other stuff that comes up in the Update Center tab in the Armoury Crate and started having problems with my Asus Tuf Gaming K7 keyboard. (Turkish Q)

    When I press the number keys above the letters they started to type random stuff like wrong numbers or letters. Here is the video of the problem I'm having: https://imgur.com/a/HFtAPS8 Sometimes some of them don't even type anything and backspace stops working completely and sometimes some of the keys starts lagging and type different stuff.

    I'm working from home and my keyboard become unusable. I was using this keyboard for like 2 months without any problems.

    This stuff started happening with the latest Armoury Crate update. Lighting on the keys change randomly to a different setting too. Even when I set them back to my preference, they change after a while or after a computer restart.

    And one other thing: at windows power options, in the "performance power plan" my setting of "never" "put the computer to sleep" option keeps reverting back to 15 minutes and 30 minutes. I'm using a 3 months old Asus Zephyrus G14 as a desktop workstation and it is always connected to the wall outlet with it's original power brick. This wasn't happening before that update.

    + I turn off the "Anime Matrix" from Armoury Crate and it turns back on after a restart.

    I tried the keyboard on a different PC (a PC without Armoury Crate installed) and problem continues. I guess something is wrong with the updated keyboard firmware?

    I contacted Asus Support and got told to uninstall the Armoury Crate with it's uninstaller tool and reinstall it. I tried it and nothing has changed. The keyboard is still unusable. I can't even enter my Windows pin at the login screen. It really is frustrating. It has been 6 days.

    Some other Turkish user with the same keyboard is having the same problem too.
    https://old.reddit.com/r/ASUS/commen...crate_profile/

    Admins or developers check my video and please acknowledge this keyboard problem and help us. At least let us know that it's being worked on and it will be fixed with a new patch or something.

    Please resond and help us. Thanks.

  2. #2
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    17

    I have the same problem. I opened a thread before, I also wrote on the Armory Crate forum. I also contacted support. Still no solution.

    https://rog.asus.com/forum/showthrea...rofile-Problem

  3. #3
    ROG Member Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    14

    same problem Asus Flare keyboard, random character. Last update is problematic

  4. #4
    ROG Member Array
    Join Date
    Apr 2014
    Reputation
    10
    Posts
    7

    I have the same problem, latest Armoury Crate 5.0.11.0 and firmware update (2.1.2.3) should be checked for Turkish keyboards. We need a fix for this.

  5. #5
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    17

    No fix has been released yet. I WILL NOT BUY ANY ASUS PRODUCT AGAIN!

  6. #6
    New ROGer Array
    Join Date
    Jan 2021
    Reputation
    33
    Posts
    4

    Aynı Sorunu Yaşıyorum

    Quote Originally Posted by vaal_zinc View Post
    I updated the Armoury Crate and the other stuff that comes up in the Update Center tab in the Armoury Crate and started having problems with my Asus Tuf Gaming K7 keyboard. (Turkish Q)

    When I press the number keys above the letters they started to type random stuff like wrong numbers or letters. Here is the video of the problem I'm having: https://imgur.com/a/HFtAPS8 Sometimes some of them don't even type anything and backspace stops working completely and sometimes some of the keys starts lagging and type different stuff.

    I'm working from home and my keyboard become unusable. I was using this keyboard for like 2 months without any problems.

    This stuff started happening with the latest Armoury Crate update. Lighting on the keys change randomly to a different setting too. Even when I set them back to my preference, they change after a while or after a computer restart.

    And one other thing: at windows power options, in the "performance power plan" my setting of "never" "put the computer to sleep" option keeps reverting back to 15 minutes and 30 minutes. I'm using a 3 months old Asus Zephyrus G14 as a desktop workstation and it is always connected to the wall outlet with it's original power brick. This wasn't happening before that update.

    + I turn off the "Anime Matrix" from Armoury Crate and it turns back on after a restart.

    I tried the keyboard on a different PC (a PC without Armoury Crate installed) and problem continues. I guess something is wrong with the updated keyboard firmware?

    I contacted Asus Support and got told to uninstall the Armoury Crate with it's uninstaller tool and reinstall it. I tried it and nothing has changed. The keyboard is still unusable. I can't even enter my Windows pin at the login screen. It really is frustrating. It has been 6 days.

    Some other Turkish user with the same keyboard is having the same problem too.
    https://old.reddit.com/r/ASUS/commen...crate_profile/

    Admins or developers check my video and please acknowledge this keyboard problem and help us. At least let us know that it's being worked on and it will be fixed with a new patch or something.

    Please resond and help us. Thanks.
    Aynı sorunu yaşıyorum. Geçici, çözüm olarak armouryde klavyeyi seçip profilde, profil 1 2 3 yerine default u seçerseniz tuşlarla ilgili sorun düzeliyor. Fakat defaultda RGB seçimini size bbırakmıyor.
    Last edited by adeniz; 02-27-2022 at 12:59 AM.

  7. #7
    ROG Member Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    8

    It's been more than 3 weeks and still no fix. Are you guys gonna provide a fix or not? What is going on? Have I made a huge mistake by buying an Asus gear?

    Give us an ETA!

  8. #8
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    17

    Support is not responding still no solution found. It shouldn't be this hard. If you fail, our warranty remains, take your products back.

  9. #9
    ROG Member Array
    Join Date
    Feb 2022
    Reputation
    10
    Posts
    14

    the site is garbage..

  10. #10
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    17

    Has anyone tried the latest update? It looks fixed.
    Son güncellemeyi deneyen var mı? Düzelmiş görünüyor.

Page 1 of 4 1 2 3 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •