Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Jan 2022

    Question Strix Scar 17 Problem with sudden stuttery display, help please

    So, I recently got an ASUS ROG Strix Scar 17 laptop. For the most part it works great, but there's this one issue that's been bugging me more and more as of late. At seemingly completely random times, both the display and the audio of my computer will become incredibly stuttery for about a second, to the point that the audio play out like th-i-i-i-i-s-s-s-s for about a second before suddenly fixing itself. It was pretty rare at first so I just ignored it, but it's now becoming noticeably more frequent. I've tried driver updates and tweaking with different settings but nothing's fixing it, does anyone have any ideas as to what could be causing this? Thank you.

    AMD Ryzen 9 5900HX with Radeon Graphics 3.30 GHz
    NVIDIA GeForce RTX 3080 16GB GDDR6
    32GB DDR4
    360Hz IPS FHD Display
    2TB SSD

  2. #2
    ROG Guru: Brown Belt Array RedSector73 PC Specs
    RedSector73 PC Specs
    Laptop (Model)FA506IU-AL130T x 2
    ProcessorAMD Ryzen 9 3900X 12-Core Processor
    Memory (part number)4 x G.SKILL F4-3800C14D-16GTZN 14-16-16-36 Samsung B-Die
    Graphics Card #1Gigabyte Aorus RTX 2080 Ti Xtreme WaterForce (GV-N208TAORUSX W-11GC)
    Sound CardArctis DAC
    MonitorAsus ROG Swift PG348Q
    Storage #1ADATA SX8200PNP 1TB
    Storage #22 x Samsung SSD 840 EVO 250GB
    CPU CoolerCoolermaster Liquid Pro Master 360
    CaseEVGA DG-87 Gunmetal Grey Gaming Case
    Power SupplyEVGA SuperNOVA G2 750W Gold Power
    Keyboard Corsair K95 RGB Platinum
    Mouse Corsair Gaming Sabre RGB Gaming Mouse
    Headset ARCTIS Pro Wireless
    Mouse Pad Cooler Master MP750 RGB Cloth Gaming Mouse Pad Extra Large
    OS Windows 11 64bit Pro
    Network RouterPfSence Intel i5-10210U 6 Port
    Accessory #1 TP-Link Gigabit 8&6 Port Switches

    Join Date
    Apr 2018

    check you using the latest AMD drivers

    and Nvidia Drivers.

    Also check your network NIC is on the latest driver.

  3. #3
    ROG Member Array
    Join Date
    Sep 2021

    I have the same problem as you say , try to post it about half year ago but no answer from ASUS. My model is Strix G733QS Ryzen 7 5800h with RTX 3080 8GB . I try many way to solve it but it did not work at all.
    List of what I try.
    1.Reinstall Window 10.
    2.Install Window 11 instead.
    3.Clean graphic driver and reinstall , Clean audio driver and reinstall.
    4.Try to update all the driver .
    5.Uninstall armoury crate.
    6.Clean install window and did not install armoury crate and any other asus software .
    Nowaday still live with it. expensive laptop with **** issue. I'm not sure that it's a defect of my product or it cause from the software of ASUS.
    and also in REDDIT , There're many people ask about this.
    Last edited by ZiliNate; 03-11-2022 at 04:49 AM.

  4. #4
    ROG Guru: Green Belt Array hexaae PC Specs
    hexaae PC Specs
    Laptop (Model)ASUS Gaming Laptop GL703GS
    MotherboardIntel HM370 Cannon Lake-H (310)
    Memory (part number)32GB DDR4 @2666MHz (dual-channel)
    Graphics Card #1NVidia GTX 1070 8GB
    Monitor1080p 144Hz 17" G-Sync AUO B173HAN03.2
    Storage #11TB SSD Crucial MX300
    Storage #2NVMe Samsung PM916
    Mouse ROG Strix Carry Wireless-BT mouse
    Mouse Pad MouseRug collection
    Headset/Speakers Realtek HD (ALC295)
    OS Windows 11 Pro x64
    Accessory #1 XBox One Bluetooth gamepad
    Accessory #2 Hori Fighting Stick Mini
    Accessory #3 4K Blu-Ray UHD USB Archgon Star
    hexaae's Avatar
    Join Date
    Feb 2015

    Sounds like a typical vrr overheating (the small mosfets lines above the CPU)

  5. #5
    ROG Member Array
    Join Date
    Sep 2021

    I got a good news for you it is a bug from AMD CPU when enabling ftpm so it will be fix soon.
    In PC can be fix by turn ftpm off but in laptop it doesn't exist and also window 11 need it. just waiting for bios patch
    Example of stutter :
    Last edited by ZiliNate; 04-10-2022 at 07:56 PM.

  6. #6
    New ROGer Array
    Join Date
    Feb 2023

    any update to this? has the fix for it been deployed yet? I still get this issue myself on my G17RS

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts